cancel
Showing results for 
Search instead for 
Did you mean: 

Installed programs on my G751JT does not get internet access

Zapmi
Level 7
Hi,

Did not find any "help" forum here, so i'll just post here instead.

I started up my brand new G751JT yesterday evening. Pretty stoked about it i started installing my softwares, and then i get a BIG problem. Installed softwares\programs does not get internet connection.
I can use my internet browser just fine, i can download stuff from the browser just fine, but installed programs does not get internet access. Win8's apps is also connected to the internet.

I've tried to add the programs to windows firewall, disabling the firewall and uninstall the antivirus with no luck.

Anyone got any good fixes i can try?
3,160 Views
4 REPLIES 4

ROGscholar
Level 7
did you try a few more other programs?

hmscott
Level 12
Zapmi wrote:
Hi,

Did not find any "help" forum here, so i'll just post here instead.

I started up my brand new G751JT yesterday evening. Pretty stoked about it i started installing my softwares, and then i get a BIG problem. Installed softwares\programs does not get internet connection.
I can use my internet browser just fine, i can download stuff from the browser just fine, but installed programs does not get internet access. Win8's apps is also connected to the internet.
I've tried to add the programs to windows firewall, disabling the firewall and uninstall the antivirus with no luck.
Anyone got any good fixes i can try?


Zapmi, what programs? What access are they trying to use? Details are important to debug. Use Task Manager to see what ports are being opened, like this, but with the missing columns showing the IP/port.

44542

Your router may also be blocking, your ISP, your government... where are you? 🙂

Running from another PC on your home network the access works ok?

Works the same on Ethernet and Wifi?

Unless you have played with proxy, installed another tool that is messing with port access... there is nothing else that comes with Windows that is going to mess with your programs access.

More info will help.

lancelot
Level 7
I was seeing exactly the same thing with G751JY. A browser had Internet access, but apparently other types of network traffic were being blocked without any warning. An example is the DirectX Web Installer (dxwebsetup.exe). It hanged trying to access the Internet. Another example is the Vidalia Relay Bundle, which also hanged.

My brute force fix for this was uninstalling a bunch of stuff from Programs and Features and restarting. The issue was gone. I'm thinking that McAfee was the culprit but I'm sorry I cannot be more definite about it because I don't want to start with a clean install again to try removing things one by one.

The things that I didn't remove:

ASUS ROG MacroKey
ASUS USB Charger Plus
ATK Package
ETDWare
Genesys USB
Intel drivers
Microsoft Office
VC redistributables
NVIDIA Graphics Driver
NVIDIA HD Audio Driver
NVIDIA PhysX
Realtek Ethernet
Thunderbolt Software
WinFlash

ManjuprasadMBas
Level 7
I recently purchased ASUS ROG G751JT, i also faced similar problem, the main culprit is MACFEE antivirus. it messes up with the firewall
if you un-install it from Programs and features. you cannot fix the firewall. you will need to format it or perform a system restore.
TO remove the software you will need Macfree Removal tool ( Google it ! ! ).
With this the internet connectivity s restored.
When installing 3rd party Anitivrus be sure to disable that antivirus's firewall or configure the antivirus's firewall to get the network connection back.