cancel
Showing results for 
Search instead for 
Did you mean: 

Huge FPS drop on G751JT

Icemixxy
Level 7
Hello everyone,

I have owned this G751JT for over a year now without any problems.
I play World of Warcraft 99% of the time, on ultra settings at 55-60 FPS with V-SYNC on.
Today when I logged on, it was fine for 10 minutes, after which my FPS suddenly dropped to about 15. I checked if Windows was updating itself, or AV running in the background and nothing. I did what anyone would, restarted the game. I had 15 FPS from the start. After that I tried restarting the laptop. It worked for 5 minutes, then again the huge drop. Tried resetting the game settings, didn't help.
I haven't installed anything in days, so I thought Nvidia drivers might have became corrupted and tried reinstalling the drivers with clean installation ticked.
Worked fine for 5-10 minutes, but it dropped again. Blew the vents with compressed air, checked temps, they were at 70-75 or so. I didn't check if that was high or not, but the fans weren't blowing out much. I checked rog forums, installed NoteBook FanControl, used the zenbook profile as suggested here and set all vents to 100%.

So at this moment I have wow open, on ultra at 12-16 fps, CPU temp at 58-61 C, GPU 48 C, PCH diode 67 C.

So it's not overheating and now my only guess is Windows has turned upside down. It's W10 x64 home by the way.
I'm somewhat afraid of sending it back in warranty, because the company I bought it from works with an asus authorized service, so I'm a bit untrustful.
My only safe option is try a Windows reinstallation.

Hoping someone has an idea that could help or experienced something similar.

Thank you
6,337 Views
10 REPLIES 10

Icemixxy
Level 7
Hi guys.
Been 3 days now, working like a charm. It was definitely something within Windows. No issues after reinstallation. Issue solved. Hope this will serve as a reference to someone with the same issue:)
Thank you for your help!