cancel
Showing results for 
Search instead for 
Did you mean: 

HDMI connection picture but no sound [solved]

steve916
Level 7
Hi all, just connected my G53 up to the TV via HDMI . I get a great picture but no sound. There is no problem with the HDMI cable or TV as my wifes laptop plays video to the TV with the same HDMI cable with no problem. My laptop has played video back in the past with no problem.
My G53 has been back to ASUS here in Melb for repairs twice earlier this year and I have not played video back since then.
the drivers are up to date.
Can anyone suggest anything else to check or try beforeI call ASUS support.

Thanks in advance
928 Views
16 REPLIES 16

I managed to fix this issue last night....

After days of troubleshooting and searching for the correct drivers, I finally found that my dilemma was due to the fact that i updated the drivers via intel and nvidia. (plus i did a fresh install of windows when i first purchased the N56JN as i prefer clean)

Solution:

If you happened to install updates via Intel or Nvidia, uninstall your drivers and start from the drivers delivered at the Asus site.
I am not certain that the nvidia drivers are to blame but i installed the original ones to be sure. ( I will update to latest tonight to test if the Nvidia drivers are the issue, which i heavily doubt)

!!!!! The original Asus site Intel VGA drivers was the last thing i reinstalled before HDMI audio finally worked!!!!!

Try to test this out to see if it works.

[QUOTE=System Wave;425714 ( I will update to latest tonight to test if the Nvidia drivers are the issue, which i heavily doubt)



I updated to the lastest Nvidia drivers so ive eliminated the fact that they are the problem....the processor VGA display drivers were the issue....

I guess Asus is not keepin up on this end but as long as you get the drivers for Intel VGA at the asus site you should be fine. I'm enjoying nice HDMI audio now!!!

Asus has the best bang for your buck computers!!!!

Thanks Man !

After gooogled it for 3 days since i connectet the tv via hdmi, i found your suggestion and SOLVED the problem !

When i installed the video driver from asus list of drivers , i checked only nvidia

Thanks Again

A fresh and Happy Owner of G750JZ-T4155D!

cl-Albert
US Customer Loyalty Agent
tzutzu95 wrote:
Hello,

I just bought an G750JS with nVidia gtx 870m but when I connect the HDMI cable the sound still came from the laptop, I searched a little and find this forum post and search in control panel for nvidia setings but in that menu this is the only seting i see 39745 And also when i plugged the hdmi cable it didn't apear the TV on the Sound section. What can I do?


Hi,

fyi.
If you're interested, you may also want to post your issue in the 'G750' section since you have the G750JS model which is actually different from the G75 series which includes the G75VW and G75VX models if you didn't already know.

Anyway, hoping you can get some solutions or ideas from other G750JS owners in the G750 section below.
http://rog.asus.com/forum/forumdisplay.php?157-G750-GX550-G550-and-G56-Gaming-Notebooks

Sorry, I didn't know that, thanks for the advice!

TenOf11
Level 7
I have the ASUS ROG G750JS which utilizes 2 video cards, an Intel HD Graphics 4600 and NVIDIA GeForce GTX 870M. The NVIDIA Control Panel only shows the 3D Settings options. When plugging in the HDMI to my Samsung TV, video worked as expected but audio only played through the laptop speakers. I uninstalled and reinstalled the NVIDIA display drivers (several times both with and with a the full clean option) with no affect.

What did work for me was to fully uninstall the Intel Graphics Driver and download the Intel Graphics Driver from the ASUS ROG G750JS downloads site. Driver version from Windows Device Manager was 10.18.10.3379.

HTH

jackadision
Level 7
steve916 wrote:
Hi all, just connected my G53 up to the TV via HDMI . I get a great picture but no sound. There is no problem with the HDMI cable or TV as my wifes laptop plays video to the TV with the same HDMI cable with no problem. My laptop has played video back in the past with no problem.
My G53 has been back to ASUS here in Melb for repairs twice earlier this year and I have not played video back since then.
the drivers are up to date.
Can anyone suggest anything else to check or try beforeI call ASUS support.

Thanks in advance


Before applying any of the below given solution, it is sugested to make sure that your HDMI cable is working perfectly as expected. If all ok, then apply the below given tricks:

Solution 1: Go with the Display Output Settings to Fix HDMI Monitor Not Working on Windows 10

Solution 2: Update Graphics Driver to Repair Windows Does Not Recognize Second Monitor

Solution 3: Run Hardware and Device Troubleshooter to Fix Monitor Not Detected by PC

Solution 4:
Verify that your HDMI device is the Default Device

Solution 5: Run System Restore

Source: http://www.pcerror-fix.com/top-5-solutions-to-fix-windows-10-not-detecting-hdmi-tv