cancel
Showing results for 
Search instead for 
Did you mean: 

graphic stuttering and frame drops in games / G551vw

patrik_cherfane
Level 7
hello guys,
i bought my G551vw and when i 1st start gaming i noticed micro stutters (frame drops)... i tried to reset my laptop and nothing... tried the latest Nvidia drivers from original website (GTX 960 M) and still the same even i tried to driver from Asus official website... i decided to send it for the company and they had to replace my board and vga with a new one, but i still have the same problem...
im running pre-installed windows 10 ... does anyone encountering similar problems ? is there any solution for this ?
Thank you
1,211 Views
11 REPLIES 11

navis995
Level 11
Please elaborate your issue.
Asus Rog G750JZ
Screen: 1920x1080 17.3'
CPU: Intel® Core™ i7-4700HQ (3.4Ghz @ -70mV)
GPU: GeForce GTX 880M 4GB (OC +125Mhz Core, +600Mhz Memory @ 1.062V)
RAM: Samsung 32GB 1600MHz
Storage #1: Samsung Evo 840 250GB
Storage #2: Samsung Evo 850 500GB
Storage #3: Seagate Barracuda 2TB
Storage #4: Samsung Evo 128GB MicroSD

navis995 wrote:
Please elaborate your issue.


well as soon as i open CS GO or Dota 2 and im playing, i have these graphics freezes for milliseconds randomly even when i just loaded in the 1st game (i think it's not an overheating issue)... and of course my games are selected under the High performance processorNividia. When i try to play League Of Legends i can see the issue more when im watching my fps counter dropping from 60 to 30 suddenly and then it goes to 60 ... Vsync is disabled in the games, and even when play my games and the lowest graphic setting i still havethe same problem...
i have latest updates from Nvidia and i still have this issue and it's annoying ...

patrik.cherfane wrote:
well as soon as i open CS GO or Dota 2 and im playing, i have these graphics freezes for milliseconds randomly even when i just loaded in the 1st game (i think it's not an overheating issue)... and of course my games are selected under the High performance processorNividia. When i try to play League Of Legends i can see the issue more when im watching my fps counter dropping from 60 to 30 suddenly and then it goes to 60 ... Vsync is disabled in the games, and even when play my games and the lowest graphic setting i still havethe same problem...
i have latest updates from Nvidia and i still have this issue and it's annoying ...



Check the T and make sure they're under 90°C, also make sure that you're plugged in.
Asus Rog G750JZ
Screen: 1920x1080 17.3'
CPU: Intel® Core™ i7-4700HQ (3.4Ghz @ -70mV)
GPU: GeForce GTX 880M 4GB (OC +125Mhz Core, +600Mhz Memory @ 1.062V)
RAM: Samsung 32GB 1600MHz
Storage #1: Samsung Evo 840 250GB
Storage #2: Samsung Evo 850 500GB
Storage #3: Seagate Barracuda 2TB
Storage #4: Samsung Evo 128GB MicroSD

navis995 wrote:
Check the T and make sure they're under 90°C, also make sure that you're plugged in.


well thank you for your help ! i found the solution after jumping from a forum to other ... it was just a silly botton in the Nvidia control panel, i had to switch the PhysX from auto selection to My graphic card ( GTX 960 M ) apparently the auto selection option was selecting my CPU... I didn't knw about that ... i had an amd graphic card ... and now it's perfectly working ...
i hope this will be helpful for others users if they are encountering such issues ...

navis995 wrote:
Check the T and make sure they're under 90°C, also make sure that you're plugged in.

i'm back here ... this frame drops and stutters are way less right now ... but i still have them !! help me again guys 😞

i need help guys !!

patrik.cherfane wrote:
i need help guys !!


Same problem here. Before it was new it is working properly but suddenly i encountered with problem. And until now the fps suddenly drops. Any solution guys?

zegfrid wrote:
Same problem here. Before it was new it is working properly but suddenly i encountered with problem. And until now the fps suddenly drops. Any solution guys?


i just removed the 1 tb hdd and replaced it with 1 tb ssd ( hyper x savage) and no more graphic stuttering... it costs me a lot but it was a solution 😛

patrik.cherfane wrote:
i just removed the 1 tb hdd and replaced it with 1 tb ssd ( hyper x savage) and no more graphic stuttering... it costs me a lot but it was a solution 😛


I still have my warranty is it still possible for me to tell the costumer service and ask for this item? Graphics stuttering is like the rendering was spiky right? That when you move around your view you see those spiky things on the sorrounding graphics.