cancel
Showing results for 
Search instead for 
Did you mean: 

GL552JX SSD upgrade - not opening up anymore

HellSource
Level 7
Hello.
I've been owning an ASUS ROG GL552JX since 2015 and I've recently bought a SSD for it, a SATA 3 to be more specific: SSD Adata Ultimate SU650 512GB SATA3 M.2. I've installed the windows, worked for 2-3 minutes then everything froze afterwards shutting down.
Now when trying to open it up, it lights up the power button, airplane mode light, and one more. After some time, the fan starts spinning too (after about a minute).
Things I've tried: - Removing/adding other RAM sticks - Hard resetting (holding the power button 20-30 seconds, with and without the battery and AC adapter) - Opening all of it up, reconnected everything
Any opinions on what's the problem or how can I solve this? Thanks!
Note: before adding the SSD, I've cleaned the insides, changed the fan (the old one made noise, pretty beaten up), changed the thermal paste. It worked perfectly until the point I've decided to add the SSD.
63 Views
0 REPLIES 0