cancel
Showing results for 
Search instead for 
Did you mean: 

G75VW - VIA AUDIO/WINDOWS 10 WORKING (Updated 01/31/16)

PudgeamusPrime
Level 9
UPDATED: 09/04/17 - Creators Update/Anniversary update fixes - Please at least update to Anniversary edition of windows 10 for these fixes to work. Thanks and Cheers.

Windows 10 Creators Update VIA AUDIO FIX
https://youtu.be/NZIyjIPCDUY

Windows 10 Anniversary Update VIA AUDIO FIX
https://youtu.be/VrQVdKnxL70

How to check your current version of Windows 10

Method 1: Hit the windows key and then type "winver" and press enter.

Method 2: Hit the windows key and type "cmd" and press Enter. Now type winver and press enter.

If you see “Version 1703” then the Windows 10 Creators Update is installed on your computer.

If you see “Version 1607” then the Windows 10 Anniversary Update is installed on your computer.

Anything lower than “Version 1607” and you will need to update your Windows 10 to at least the Anniversary Update. We recommend updating to the creator's update.

Anything higher than “Version 1703” you are probably on insiders build of Windows 10. Try the Creators Update fix but we can't guarantee it will work.
245,366 Views
181 REPLIES 181

Same problem here. Don't really know which one sucks the most: Asus or Windows...

Yeah, Microsoft is really ****ting the bed with windows 10. Hopefully Via can get Vdeck back up and running quick. I am trying to figure out a work around but I think it will be up to via.

Hoder
Level 7
Thank you! Finally everything - speakers, headphones, HDMI are all working perfectly.

paul_bww
Level 7
F*CK THIS S*IT! I'm going back to windows 7

Sentinel wrote:
Apparently I am having a different problem, the sound in the speakers and headphones are working but to a point. The Sub isn't working at all, my model is G75VW-BBK5 and found the only way to get it to work was to download the Codec from VIA but that would run all the sounds. Yes both speakers and headphones would be running at all times and I kind need both to be working properly so I can have some music at work for everyone and at home to myself and not bother anyone in the house.


Chondylon wrote:
Same issue here, (G75VW-RS72), I'm unable to get the sound to work properly on my headphones. The sound goes out on both the speakers and the headphones and after 10 sec or so, it just stops. It will work again if a unplug the headphones though.

I kinda find annoying that I'm not able to keep up to date due to drivers issues, and a sound problem when I mostly use my computer for streaming and video making is sort of a big problem, too...


Hoder wrote:
Thank you! Finally everything - speakers, headphones, HDMI are all working perfectly.


gammite wrote:
thanks. it took years for someone to get this right. i appreciate the help.


paul.bww wrote:
Same problem here. Don't really know which one sucks the most: Asus or Windows...


paul.bww wrote:
F*CK THIS S*IT! I'm going back to windows 7



Awesome. Please try the new driver on the front page. It seems to have fix VDECK.
https://rog.asus.com/forum/showthread.php?72299-G75VW-VIA-AUDIO-WINDOWS-10-Work-Around

PudgeamusPrime
Level 9
Hello everyone. I contacted VIA about the Windows 10 Fall update and will have you know that the audio chipset in the asus G75VW will be supported in Windows 10. No ETA on a fix. They seem rather oblivious to the issue at the moment but I'm sure we will get another working driver soonish.

PudgeamusPrime wrote:
Hello everyone. I contacted VIA about the Windows 10 Fall update and will have you know that the audio chipset in the asus G75VW will be supported in Windows 10. No ETA on a fix. They seem rather oblivious to the issue at the moment but I'm sure we will get another working driver soonish.


Hello..any updates? This issue is driving me nuts!!

No updates. We are literally just waiting for them to update the driver.. The last update was in august which fixed everything.. but then Microsoft release this fall update so it might be months. Hopefully not though.

paul.bww wrote:
Hello..any updates? This issue is driving me nuts!!


Yes. Please try the new driver on the front page. It seems to have fix VDECK.
https://rog.asus.com/forum/showthread.php?72299-G75VW-VIA-AUDIO-WINDOWS-10-Work-Around

Hammertymme
Level 7
PudgeamusPrime wrote:
ATTENTION: If you received the windows 10 fall update (Right click start button, If the menu is black you have the fall update) Your VDECK software is most likely broken. I contacted via and they said they are supporting the chipset found in the ASUS G75VW. That said, Still follow the walk through below as the headphone redirection still works in the software. Everything else will have to be controlled through properties in sound under speakers on the enhancements tab.

Hello Everyone. So Apparently via updated their drivers with VDECK software included for the ASUS G75VW which fixes the issues with VDECK and the audio drivers working with windows 10

Step 1. Download updated Via driver

Driver Link - https://www.dropbox.com/s/qhuzn17651o9jsu/VIAHDAud_v11_1000b_08182015.zip?dl=0

Step 2. Extract driver from .zip and install

Step 3. Reboot. (VDECK software will promt you to install after reboot. This is a crucial step)

Step 4. Once your ASUS G75VW is booted install VDECK software when prompted.

Step 5. Open up VDECK software and click on the configuration icon in the bottom right hand corner

Image

Step 6. Select the option redirect headphones

Image

Step 7. right click on the start icon in the bottom right hand corner and then click control panel. Now select sound. Highlight speakers and then click configure like in the picture below.

Image

Step 8. Check 5.1 Surround and click next.

Image

Step 9. Now Uncheck Side Pair.

Image

Step 10. Uncheck Surround speakers (If you are not using surround sound) and click next then finish)

Image

You should now have working sub woofer and headphones.

(NOTE: Close then reopen whatever source you are using for testing at first after selecting "Redirect Headphones" when testing the headphone jack - Audio player, Browser, Spotify etc)

Thanks to everyone for all the tips below!



So the instructions are good but the download is not. Here is a better link: http://download.ecs.com.tw/dlfileecs/driver/mb/sound/sound_win10_via.zip