cancel
Showing results for 
Search instead for 
Did you mean: 

G75VW - VIA AUDIO/WINDOWS 10 WORKING (Updated 01/31/16)

PudgeamusPrime
Level 9
UPDATED: 09/04/17 - Creators Update/Anniversary update fixes - Please at least update to Anniversary edition of windows 10 for these fixes to work. Thanks and Cheers.

Windows 10 Creators Update VIA AUDIO FIX
https://youtu.be/NZIyjIPCDUY

Windows 10 Anniversary Update VIA AUDIO FIX
https://youtu.be/VrQVdKnxL70

How to check your current version of Windows 10

Method 1: Hit the windows key and then type "winver" and press enter.

Method 2: Hit the windows key and type "cmd" and press Enter. Now type winver and press enter.

If you see “Version 1703” then the Windows 10 Creators Update is installed on your computer.

If you see “Version 1607” then the Windows 10 Anniversary Update is installed on your computer.

Anything lower than “Version 1607” and you will need to update your Windows 10 to at least the Anniversary Update. We recommend updating to the creator's update.

Anything higher than “Version 1703” you are probably on insiders build of Windows 10. Try the Creators Update fix but we can't guarantee it will work.
243,470 Views
181 REPLIES 181

GodsApocalypse
Level 7
Have you found other issues with drivers after installing Win10? Does this driver issue also apply to G75VX? I am considering the upgrade. Was DirectX 12 worth it? How is the system now overall after the install of Win10? Thanks for the feedback!

System is running fine.
I am in I.T and I have had windows 10 RTM build for some time installed on my laptop. The only issue I had was the Windows 8.1 Via software or windows 7 software would not work with windows 10. Everything else works fine. I updated my ATK from a new rog model, Not sure which. If your rog version uses via audio it might also use the same audio chip. If you have via audio and 2.1 sound you will probably run into the same issue . Follow the tutorial above and uninstall vdeck or whatever via software you have as you will now configure your sound through the enhancements tab in sound under configure. Natively the nvidia 600 series video cards support dx11 and dx12 api as well but it may not support all features of directx 12 as they are a bit older and DX12 was in mind but also in it's infancy at the time. That said.. I have not had a chance to test games yet as my school schedule has been crazy as of late.. I mostly installed 10 for features, Smaller footprint, Performance and Startmenu.

Here is an article explaining DX12 and the Nvidia 600 Series - https://en.wikipedia.org/wiki/GeForce_600_series

I would recommend doing an update so if you run into major issues you can role it back.

I also had issues with certain pieces of software which just had to be re-installed. (Not a biggy)
- Vmware
- Nik Photoshop Plugin

kakero
Level 7
So are you saying the Win7 drivers work better on Win10 than the Win8 drivers? I wonder if this works on G55VW too (that's my system) not sure how different the audio chipsets between these models are.

kakero wrote:
So are you saying the Win7 drivers work better on Win10 than the Win8 drivers? I wonder if this works on G55VW too (that's my system) not sure how different the audio chipsets between these models are.


Yes that is correct. I always found the Windows 7 software worked better on 8 and 8.1 as well with the g75vw on multiple installs. I consider it the most stable driver so I recommend it. The key here really though is just to remove via's software so it lets go of the audio card and then force windows to recognize 2.1 sound in a kinda manipulative way so that it works correctly and you also have the features you previously had with the via audio software but through windows enhancements tab instead.

Hope it helps 🙂

Cheers.

PudgeamusPrime wrote:
Yes that is correct. I always found the Windows 7 software worked better on 8 and 8.1 as well with the g75vw on multiple installs. I consider it the most stable driver so I recommend it. The key here really though is just to remove via's software so it lets go of the audio card and then force windows to recognize 2.1 sound in a kinda manipulative way so that it works correctly and you also have the features you previously had with the via audio software but through windows enhancements tab instead.

Hope it helps 🙂

Cheers.


Windows 7 drivers for this audio chip would not install for me on windows 10 after the Nov big update, so I did what is posted here and everything is working.

That's good news. I will test this out to see how it works. The windows 10 driver with the update is garbage at the moment.

Steve M wrote:
Windows 7 drivers for this audio chip would not install for me on windows 10 after the Nov big update, so I did what is posted here and everything is working.


Awesome. Please try the new driver on the front page. It seems to have fix VDECK.
https://rog.asus.com/forum/showthread.php?72299-G75VW-VIA-AUDIO-WINDOWS-10-Work-Around

kakero
Level 7
Tried your method on my G55VW: so far it removed the problem of having two separate playback devices for the speakers and the audio jack (headphones) that I have to set to default whenever I plug in/take out a set of earphones. However, I still can't configure it as a surround/2.1 device. I only have a stereo option, so no subwoofer yet. Will try other driver versions when I have time later, and report back whatever would work best.

kakero wrote:
Tried your method on my G55VW: so far it removed the problem of having two separate playback devices for the speakers and the audio jack (headphones) that I have to set to default whenever I plug in/take out a set of earphones. However, I still can't configure it as a surround/2.1 device. I only have a stereo option, so no subwoofer yet. Will try other driver versions when I have time later, and report back whatever would work best.


50683

Did you select 2.1 in the enhancements tab? Also did you configure your laptop as 5.1 and shut off the rear speakers?