Showing results for 
Search instead for 
Did you mean: 

G75VW Solution: Is your External USB 3.0 Dual drive dock dropping USB connection???

Level 9
Ok. Issue has been fixed the Asus G75VW USB 3.0 is not junk. It was all Jmicron JMS539 firmware And I now have the solutuion.

My Areca ARC-5040 Raid Box is now working in full USB 3.0 with all 7 Volumes and Have an idea as to why the first JMS539 firmware update created the drop out issue in the first place with multiple volumes.

See ARECA sent me FwUpdateTool_v1_16_00_T2.exe and JMS539_PM_255.

However, their bin was 37K in size like all others on the web. The Whole firmware area is 60K + 4K of NVRAM = 64K. ARECA's bin didn't update the whole Firmware area.
I bet there was stuff unchange in the NVRAM area on the update.

I finally got though to JMICRON in Taiwan. They sent me (unzipped: JMS539FwUpdateTool_v010.exe) (ie: Firmware the lastest firmware for the end user. This fixed my usb 3.0 drop issue and I had good speed but created a new issue.
I now had only one volume vise seven in my Raid Stack. But it proved the connection drops were cause by the firmware.

Once I was done testing, I re-installed the 37K JMS539_PM_255. ARECA had originally sent me to correct the "Device Failed to Load Code(10)" error in Windows 7 between the JMS539 bridging chip and the Intel XHCI USB 3.0 embedded controller. I Retested the Drive stack with Crystal Disk Mark 3.0.4, and low a behold the connection drop issue was gone. And all 7 of my raid volumes are working.

Here's the crystal mark scroes
CrystalDiskMark 3.0.2 x64 (C) 2007-2013 hiyohiyo
Crystal Dew World :
* MB/s = 1,000,000 byte/s [SATA/300 = 300,000,000 byte/s]

Sequential Read : 151.528 MB/s
Sequential Write : 173.147 MB/s
Random Read 512KB : 17.702 MB/s
Random Write 512KB : 48.779 MB/s
Random Read 4KB (QD=1) : 1.094 MB/s [ 267.2 IOPS]
Random Write 4KB (QD=1) : 2.100 MB/s [ 512.6 IOPS]
Random Read 4KB (QD=32) : 1.073 MB/s [ 262.0 IOPS]
Random Write 4KB (QD=32) : 2.143 MB/s [ 523.1 IOPS]

Test : 1000 MB [J: 55.6% (1035.8/1862.5 GB)] (x9)
Date : 2013/02/26 4:48:34
OS : Windows 7 Ultimate Edition SP1 [6.1 Build 7601] (x64)

Now this is important too a great many people with those External USB 3.0 Dual Slot port Drive docks using the JMS539.

My chip is:
1012 LGBA1 A

First update the dock with . It re-writes the whole 64K firmware. You only get one volume. But, you fix the NVRAM area data. Then re-install the 37K JMS539_PM_255. on top of that and you DOCK IS MOST LIKELY FIXED for dual hard drive support without connection drop outs just like my RAID STACK is now.

Here a full 64K copy of the working firmware zip. Unzip it to where your going to use it from. Don't move or copy it with windows. Windows will attach metadata to the image and bust the firmware. You need FwUpdateTool_v1_16_00_T2.exe to flash it. it's at inside the firmware package.

Level 9
wow, thank for sharing, so have you try install in ASUS G75VW laptop?

I use the ARECA ARC-5040 Revision 1.1 (ie: USB 3.0 version) External RAID box with my G75VW Laptop on the USB 3.0 bus now.

This thread was directed at anyone using a USB 3.0 multi drive/volume device that uses the JMICRON JMS539 chip and is having drop issues. I myseld own two devices using the chip. The raid unit and a Sata to usb 3.0 Sata external t/s cable t/s.

I have had this problem with my 1 TB Western Digital USB 3.0 drive. There are several things at play here:
1) The lack of maturity in USB 3.0 drivers - Intel only recently started embedding the USB 3 controller on the motherboard
2) Extra pins - there are twice as many pins in a USB 3.0 port, stacked in two rows of four, making the orientation of the cable much more sensitive.
3) Lack of maturity in USB 3.0 devices - this is getting better along with #1.

My USB 3.0 flash drive (Microcenter) seems to work just fine, so it may be the device.
I am disturbed because I cannot break my system...found out there were others trying to cope! We have a support group on here, if your system will not break, please join!
We now have 178 people whose systems will not break! Yippee! 🙂
LINUX Users, we have a group!

Hi emurach

Is there any chance you could upload or attach that file? I sent an email to jmicron asking for it but got no reply. I tried flashing your 64k file but am still getting disconnects with my Akasa dock so I'd like to try the firmware.

Not holding out much hope of it working to be honest. But I've tried everything else.

Level 9
To the guest that whated the firmware for the jmicron. Join the forum. The firmware was attached to my oringinal post in the forum. If you join the forum you could just download it from the post. I can't message you back since you were a guest.

I have experienced some problems with a 3 Tb Lacie Minimus 3.0 and my g75vw. Connection suddenly dropped every now and then for just a moment. I also replaced the cable but no luck. For some reason I found a cable - given with a 2tb Seagate Expansion - which I could replace and the problem never occured again.

Level 7

Can somebody post FwUpdateTool_v1_16_00_T2.exe as the firmware update tool seems to be no longer available, especially at station-drivers ?


Not sure what your asking for, but all tested and approved drivers are located Asus Support Downloads
G752VY-DH72 Win 10 Pro
512 GB M.2 Samsung 960 Pro
1 TB Samsung 850 pro 2.5 format
980m GTX 4 GB
32GB DDR 4 Standard RAM

Z97 PRO WiFi I7 4790K
Windows 10 Pro
Z97 -A
Windows 10 Pro


I was talking about the JMicron software tool for updating the firmware of the JMicron JMS539 controller of an external HDD enclosure.

Somebody who posted a message in this thread used it.