cancel
Showing results for 
Search instead for 
Did you mean: 

G75VW replaced GPU and wont boot [solved]

XGamer12
Level 8
G75VW 670m GPU fried and i replaced it with the same part # GPU. The keyboard and indicators light up, Hard drive makes a noise with intel/ROG on screen, but shuts off right away, fans dont turn on. any advice?
468 Views
5 REPLIES 5

xeromist
Moderator
I would go back and reseat the card, check for loose connectors, pinched wires, etc. Anything you touched during disassembly should be double checked. If everything is solid you may have a faulty motherboard or your seller may have sold you a bum GPU.

Also note that if you just replaced it with the same model of GPU and not a GPU from a G75VW there might be a firmware difference that would make it incompatible. Even if the hardware is the same there are differences between manufacturers at the firmware level. Unfortunately without a working machine there's no way to flash another firmware onto the card.
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

Thank you. I will disassemble again, reseed and check over again. I will post an update.

xeromist wrote:
I would go back and reseat the card, check for loose connectors, pinched wires, etc. Anything you touched during disassembly should be double checked. If everything is solid you may have a faulty motherboard or your seller may have sold you a bum GPU.

Also note that if you just replaced it with the same model of GPU and not a GPU from a G75VW there might be a firmware difference that would make it incompatible. Even if the hardware is the same there are differences between manufacturers at the firmware level. Unfortunately without a working machine there's no way to flash another firmware onto the card.

toying with it some more today and i popped up the keyboard and armrest. The power cable completely removed from the motherboard and the keyboard. i didnt know that it could unhook from the keyboard aswell.. well i reconnected them and starting the laptop it booted and went to windows!! i guess this could be one thing to check aswell for those having boot problems..

update: upon closer look the cable between the power button and motherboard has split and doesnt have good contact. ordering a new power/mb cord.

xeromist wrote:
I would go back and reseat the card, check for loose connectors, pinched wires, etc. Anything you touched during disassembly should be double checked. If everything is solid you may have a faulty motherboard or your seller may have sold you a bum GPU.

Also note that if you just replaced it with the same model of GPU and not a GPU from a G75VW there might be a firmware difference that would make it incompatible. Even if the hardware is the same there are differences between manufacturers at the firmware level. Unfortunately without a working machine there's no way to flash another firmware onto the card.

adeboye
Level 7
Hello, where did you get your gpu from, been searching for over a month for the 670m with limited success
XGamer12 wrote:
G75VW 670m GPU fried and i replaced it with the same part # GPU. The keyboard and indicators light up, Hard drive makes a noise with intel/ROG on screen, but shuts off right away, fans dont turn on. any advice?

adeboye wrote:
Hello, where did you get your gpu from, been searching for over a month for the 670m with limited success


Try to Private Message (PM) XGamer12 directly.
G752VSK, G75VW-3D, G51J, G1S
Homebuilt Windows Server