cancel
Showing results for 
Search instead for 
Did you mean: 

G752vy Oddly Low Framerate

abluejelly
Level 7
So playing League of Legends, which is so simple a toaster can run it at minimum.
I'm used to buttery 75 gsync-locked.... so I was really surprised when today I was getting 44-49.
Tried dropping the graphics settings, and still got 44-49 (which is really weird imo).
Killed all other apps, reinstalled the drivers (doing a clean reinstall as well), disabled Battery Boost, made sure everything (I could find) was told performance rather than power saving.... And neither fan is obstructed.
The best I've been able to do is a slight bump in the consistent range to 46-52 or so.

Note that this is both in and out of combat, and that immediately after changing the graphics settings, I'd be at 75 until I moved the camera.

Calling up Microsoft's advanced Process Explorer's GPU tab under System Information, I see it's using solely "engine 9" (not quite sure what that means). Curious, I ran a more standardized tester.
3DMark's Time Spy was free, and the rig scored 2998 (19.1/16.44 fps) GPU and 3750 (12.6fps) CPU with G-Sync off. Process Explorer reported a peak of only ~27% GPU usage across all 23 "engines", which seems odd considering how all-cylinders that should have been- but without a clue as to what is meant by "engine", that could simply be caused by the maximum degree of parallelization and/or each "engine" has a specific function rather than being general purpose.


Anybody got any ideas? Alternatively, is my 3DMark score lower than it should be, or is this some weird issue on League's end?

--

Only real change from stock I've made is switching Win10 to Education Edition, which I got free through my university and Microsoft billed as basically Enterprise just without Cortana. I've also performed the bios update (to 213). I'd be willing to purchase Pro if it solves this problem, but I was having no issues playing Warframe on max after switching to Edu.Ed. These problems were sourced from likely two weeks ago Sunday (2016-12-04), after a graphics driver update errored in the middle of it. I would have investigated it more at the time, but when you're working on a term paper due the following day, a graphics card crash that doesn't take the monitor with it is pretty ignorable. I would assume any "damage" caused by that would have been repaired by the "clean install" option when updating the graphics drivers.

Also note: GPU reports v4.48.599 on 3DMark Time Spy. I remember my old g73jh had an issue with the vbios and newer drivers- did lightning perhaps strike twice on that issue?
1,962 Views
0 REPLIES 0