Showing results for 
Search instead for 
Did you mean: 

G752VY Freeze Problem

Level 7
So i have 2 G752VY, one of my G752VY freeze during boot, or sometimes freeze during normal usage.

Already did a clean install for windows but still Freeze sometimes.
i have to force restart every time it freeze.

Do the Stock samsung 951 Nvme ssd damages?

Level 13
First suggestion is to set Bios to default and go back to the original image with the default drivers etc.

Id highly doubt the SSD is the culprit. Typically if an SSD fails, it just fails, It will lock up and upon reboot you will get No disk found.
My guess is driver or setting related.

“Two things are infinite: the universe and human stupidity, I'm not sure about the former” ~ Albert Einstein

Level 7
The problem is there when using original image, so then i move to windows 10 pro. Same problem again.

Some time it cant even boot, it stuck on windows 10 loading screen ( rotating ring ), everything just jammed. Bios is set to default.
but sometimes it can boot normally. I will replace with samsung 950 Pro once available in my region.

Level 13
One other thing you can do to rule it out. Clone the image to the HDD and pull the SSD and let it boot from there. Granted boot times and other performance related the the drive will be present but if it still locks up you know its not the SSD which I suspect it is not. Better to RMA sooner rather than later if its a hardware issue.

“Two things are infinite: the universe and human stupidity, I'm not sure about the former” ~ Albert Einstein

Level 7
I replaced the SSD 951 from the another asus G752, now seems to be working fine. I will test again for few days before rma it.

RMA team in my country is bunch of idiot, that is why asus reputations in my country sucks. i don't really want to meet them either. If asus allow, just let me do the RMA myself, i can work with RMA team for free, no need any salary until i fix my G752. I guess i'm far more professional than them.

I can FIX and RMA 30 to 50 PC/notebooks a day. compared to that bunch of idiot.

Level 7

Intel Skylake bug causes PCs to freeze during complex workloads!
I did run a prime95, after that.... the problem begin..

Hi all,

I have the same issue with my G752VY.

I tried using only the right side USBs - same.

Used with low CPU load - same.

Have purchased a gaming cooler device to reduce heating - nothing changes.

Tried Windows 10, Windows 10 Creators Update, Debian 8.5 Jessie with backports for NVMe support, Debian 9.0 Stretch, Debian 9.1 Stretch - same.

Used only 1 external monitor via HDMI - freezes.

When using Wacom 27QHD with USB+USB-C/Mini-displayport connectivity, it freezes like 3-5 times per day IN THE MIDDLE OF THE WORK DAMNIT.

I thought it was due to the original SSDs. So I have bought Samsung 950 Pro NVMe M.2. Nothing changed (worked faster when it worked).

I have specifically waited almost 1 year for 6700HQ model with 64GB RAM support, hoping to make an investment for at least 5 years. And got this?

This is insane.

I have paid USD 2600 for what, for being unpaid beta tester???

(-) Now to upgrade RAM to 64GB I have to tear the whole laptop apart (!!!)
(-) It leaks electricity via USB ports when OFF (!!!) - i.e. with cooler/mouse connected to it, it has 64% left overnight; figured it out in an airplane when I did not have enough battery to get the job done;
(-) It strikes my with an electricity if I touch my 3.5mm headphones' audio cable (!?)
(-) I get little electricity shocks if I touch the back of the laptop's body
(-) The back-lid lights may still stay turned on after I turn off the laptop. So I have to turn on the laptop, wait a ew seconds and turn off it again - then the lights are off and I can sleep.

Bottomline: I am reisntalling, and reinstalling, fixing and fixing just to try to make something to work that is expected to work out of the box.

Instead of earning money with this tool, I am loosing money because I have to work 2 hours extra EVERY DAY to make it work.

I have even made bash scripts to make Debian reinstalls & xfce4 setups faster.

THE ONLY TIME when it does NOT freeze - is when I am using the laptop alone with my G502 USB3 wired mouse.

I should have rather purchased an Alienware. I am now paying that price difference with my time. Taking professional losses and reputation risks.

This ASUS G752VY Laptop is a good looking toy, which is great only when it works (60% of the time). For a toy it is too expensive, if you would ask me.

It does totally break my workflow, always, everyday.

I have to reboot/reinstall in the middle of an intense professional work.

That is unacceptable.

The worst purchase decision in my 18 years professional career. Now I am totally screwed and f#$%ed.

I have been thinking that I was cursed or damned or something. Now I just cannot get rid of this 4.5kg beast and my business goes downhill as I spend 1-2 hours everyday to recover from all these freezes.

Yes it looks amazing. It won RedDot Design Award for that. That is great.

But it does not make any sense whatsoever when it does not work.

Thank you, ASUS, for the Red Dot Design Award winning insolvency enhancing headache.

Now I am going to replace this toy with something else. FCUK! (French Connection)

And since it weighs 4.5 KG and I always travel, will have to sell it with a significant price drop (now it is NEW on Amazon for USD 1600 - USD 1000 price drop during the year!? how nice is that huh)


Wacom 27QHD, Pro Pen, EK Remote (USB3 right side, USB-C/Mini-displayport)
Logitech G502 USB3 wired mouse (USB via Wacom)
Dell Ultrasharp 24" monitor (HDMI right side)
Coolermaster SF-17 (USB3 right side)
APC UPS 1100VA (USB management, surge protection)

Guys, if you read this, do something. You are ruining ASUS brand. You are no longer making the Samurai's swords as you have used before.

OH YES I HAVE TO ADD that I am using ASUS laptops almost exclusively since my first 17" ASUS back into the 2005 (motherboard burned after 2 yrs of 14h 6/7 daily use and replacement was priced at a price about USD 600 less than the price that I have paid for a new laptop). Needless to say that I am severely, absolutely disappointed.



Status Under Review
Disable Fastboot, and report if issue persists.