Showing results for 
Search instead for 
Did you mean: 

G752VY Bios 208 unlocks XTU, but errors on any changes?

Level 10
This is a new thread for running XTU on the G752. I didnt want to hijack another thread for a completely different issue then the OP's original post. This is a reply to this thread:

This is in response to JustinThyme's post:

So it looks like the XTU multipliers are unlocked when Bios 208 is applied. I saw you mentioning going back to 206 and I didnt realize a new Bios was released in December, so I went ahead and applied it from the website (208). I then went into XTU and was happy to see the multiplier is now adjustable along with other options, but I cant seem to get anything to change. Im a little nervous to try anything too high because the G750 I had was adjustable but only by 200Mhz and was locked to where you could not pass that multiplier, there seems to be no limitation in place on Bios 208 with the multiplier, not sure if thats intentional or not . So I tried the same and hoped I didnt run into a point where I would have to tear my G752 down to reach the CMOS battery for a reset like you did..

First, it looks like almost all changes prompt a "reboot required" yellow power button next to the setting in . Not a big deal but if I remember right, on the G750, this was not needed. You would apply a bump in the multiplier and it was be effective immediately, no reboot required.
Second, Im getting an XTU error upon reboot. I havent messed with it that much, but it seems no matter what is changed, this error comes up and no changes are applied.

Anyone else ran into this or know if there is a way to get the settings to apply? I would live to be able to bump up the processor if at all possible.

XTU after 208 Bios is applied:


Error after reboot:

(ROG has simply become too expensive compared to the competition with same specs... 😞 )
MSI GE75 Raider 10SGS - i7 10750H - RTX 2080 Super - 32GB Ram - 1TB WD NVMe - 2TB 960 EVO - 300Hz 17inch Display
RETIRED: ALIENWARE R17 R5 - i7 8750H - GTX 1070 @ 1.9Ghz - 16GB DDR4 - NVMe 970 EVO 1TB - SSD 960 EVO 1TB

Level 7
on ealier version on xtu i can change my fsb to 100 now its but when i changed it to 100.23 to matching with showed 100 at 3600 or 3700 it chrashed sometimes. the last version the fsb changing has no effect for me! i still on 99.77 sometimes 99,88 but never the 100mhz.

Level 13
I had the same results. I believe the CPU is locked, had the same result with just minor changes. It would just come back up saying it couldnt be applied. You damn sure don't want to change the memory settings!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

“Two things are infinite: the universe and human stupidity, I'm not sure about the former” ~ Albert Einstein