Showing results for 
Search instead for 
Did you mean: 

G752VSK Lagging Doing Nothing!

Level 8
Hi all, I've recently bought a ROG G752VSK and for a high-end computer I would much appreciate if someone could advise on my performance issues why it's performing so poorly. Firstly I'll list specs:

  • RAM - 32 GB;
  • Processor: Intel(R) Core(TM) i7-7820HK CPU @ 2.90 GHz
  • Windows 10 Pro; 64-Bit Architecture;
  • 2 number 1020 x 720 HD Monitors;
  • 76 Mbits/Second

Performance Issues
Watching Netflix and typing this is pretty much inoperable. Netflix is lagging like hell and words are disapeering from the screen.
ROG Gaming Center (1.png)
Is showing GPU Memory red at 4998 MHz;
CPU Stays at 2394 MHz most of the time which seems remarkably high given it's hardly doing anything.

Task Manager (2.png)
Quite different readings from Task Manager compared to ROG Gaming Center. I would say I was reading ROG Gaming Center wrong but can't be with the GPU reading bar graphic showing that the bar is displaying the quantity being used.

Actions Taken

  • I tried deleting the Graphics Card Driver NVDIA via Uninstalling Programmes in the Control Panel, all drivers reinstalled themselves upon restarting with the exception of the '3D Driver' - NO IMPROVEMENT!;
  • Was running Netflix in Firefox, changed the cache to empty only when at 700 MB instead of 350 MB - NO IMPROVEMENT!;
  • Tried running Netflix in Chrome, better definition but even more annoyingly a smaller lag every 5 seconds;
  • Contacted Asus, they advised this machine should not struggle with this whatsoever however Asus' support is quite poor and will get a standardised response in a couple of days and if that doesn't help then I need to send it to a service centre and will end up being without a computer for months; where they will most likely not replicate the problem as they will not be using the same external monitors. They should be logging in remotely to look at this;
  • I turned refresh rates way down in the NVDIA driver (Desktop > Right-Click> Display Settings> NVIDIA Control Panel> 60 MHz as low as it can go on the laptop display screen and 50 MHz on the external monitors;
  • Scanned for viruses/ malware; showing as clean.

Does anyone have any suggestions for this?

EDITED: Sorry pics are not uploading.

Does the same problem occur when using only the built-in screen?
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

Hi Xeromist, thanks for your reply.

No it seems fine on the single laptop screen, I think Graphics Card too, but must be settings as this computer must be powerful enough to do them little tasks.

Don't get me wrong I need it to work a Measuring Programme (300 MB RAM), another programme (42 MB RAM) and Netflix, but it should be fine for this.

I agree it should be able to do basic tasks but I'm thinking the Nvidia driver is having trouble figuring out what to do with your display configuration. I would try running all three displays at the same resolution and refresh rate to see if that helps.
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

Thanks Xeromist,

Yes I think you're right about the Graphics Card, I've changed the refresh rate to 60MHz on all screens (resolution was the same on all orginally) but not enjoying any improvement at the moment.

I'll have a look on the Asus website and see if there are any newer drivers as this was bad to setup from the start.; though I do think I'm on the most recent/ recommended as only bought it a few weeks ago.
I had to use the NVDIA Control Panel to get the external monitors working in the first place if I remember correctly.

Additional Steps Taken

  • Disabled hardware acceleration in Firefox - This seems to max-out the GPU less however I'm not confident from ROG Gamers readings. GPU is only at 30% the very highest I've seen it at 3.57 GHz so this machine is nowhere near breaking a sweat yet;
  • Installed Startech USB Driver - NO IMPROVEMENT, does not want to select it as a driver and uses the Windows Driver!;
  • Followed the below article - Steps in greater detail below - NO IMPROVEMENT!; and found nothing (good really as no Malware) until I was up to the stage of SlimDrivers which noticed half a dozen out of date drivers; mostly NVDIA which was good news.

I upgraded, restarted and haven't seen much of an improvement. The ROG GPU readings sometimes seem better (probably because the Graphics Card isn't being used to accelerate Firefox now) but Netflix is unwatchable still. Still getting intermittent bad typing, working with files seems a bit better; but this high-end machine should be zinging!
I've also noticed my mouse is failing more, I'm clicking and dragging sometimes and it's not registering sometimes.

The article seems a bit faltered towards the end 'you can remove the video drivers, download Driver Fusion or 3DGuru's Driver Sweeper to really remove Nvidia components, reboot and you will be in VGA mode, then download and reinstall the latest drivers.' Treexy Driver Fusion Free was showing 63 Registry Entries, I clicked on clean and it now shows 113 entries and advises need to upgrade to premium - stay away from Treexy Driver Fusion Free!

Asus website has a new 310 BIOS though I'd rather not delve into that serious stuff yet as I've been away from Windows a long time and things have changed a lot and I'm out of my depth.

Hmm, you could also try disconnecting one external screen & then the other to see if it's a particular connection. If it turns out the HDMI is lagging you then there are DP splitters which could allow you to run both externals off of a single port.
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

Thanks Xeromist, good suggestion - I wasn't expecting it but it seems the problem is the HDMI (thought it would be the VGA/ USB port).

Well at least we've narrowed it down a bit, I'll keep trying, thanks a lot for your input; much appreciated.

It's running fine through the Netflix app (was only able to download in the Microsoft Store just now; been trying for ages).

I probably shouldn't really mark this as solved but I've tried a lot of things; I think it's a Netflix issue; not a browser as it's fine in Youtube; but Netflix.

No worries, I won't close your thread. But if you have new information or the question has changed you might want to update your OP to reflect the latest information.
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…