Showing results for 
Search instead for 
Did you mean: 

G752VL Mouse Pad and Mouse Pad Buttons Stopped Functioning ?

Level 7
Greetings. Out of the blue my mouse pad and associated buttions stoped functioning (G752VL). I use a microsoft wireless mouse but I know that the built in mouse pad and its two keys should still operate. When I disconnect the trasciever for my wireless mouse, the built in mouse pad and its two keys still do not function.
Several days ago, I installed 64GB of ram, however the pad and buttons still worked afterwards. There were no other hardware installs. Also, no additional software or driver loads. Just stopped out of the blue.

Device Manager under the Human Interface Devices shows that the IC2 HID Device has a yellow exclamation point. Clicking on it, thus entering the properties page for IC2HID, shows the following message: "This device cannot start. (Code 10) A request for the HID descriptor failed."

A driver is loaded. Driver Date: 6/21/2006 Driver Version: 10.0.14393.0

Thinking perhaps I pressed a combination of keys while typing on the keyboard that disabled the mouse pad.

Any help would be appreciated.

ASUS G752VL -- i7 6700HQ -- GTX 965M -- 64GB DDR4 -- Windows 10 64 bit -- Editing Platform

Level 7
If you didn't know, on all ROG laptops you have hotkeys that control a variety of functions. Pressing a combination of the FN+ F1-12 keys will yield a shortcut, each key has a picture of it's function. Make sure you didn't accidentally just hit FN+F8 while you were trying to adjust volume or change displays, it can happen. FN+F8 disables/enables the touchpad and l/r click buttons, mainly for convenience so your palms aren't hitting the pad while your trying to type making your mouse fly all over clicking random **** lol.

If that doesn't fix it, your driver is old as phuck - hit the windows key or click the search bar next to start/cortana and type "updates" - check for windows updates - get any that pop up. Windows 10 includes drivers with updates now so it's the easiest fix normally.

If not find the touchpad icon/folder and go to properties, drivers, and click to have windows search/install a new driver if possible.

If not go to ASUS website enter your model/OS and download the newest ATK package.

This happens on other models as well and the cause is the Windows upgrade to 1607 ( Anniversary ).
The fix for me was downloading the touch pad driver from Asus support and instead of reinstall, using uninstall option.
Then I just let Windows install whatever it wants ( at reboot ).

I still do not have a controlling software for the gestures, but the touch pad works properly every time now. And you can use Windows options from settings ( the new settings , not Control Panel ) to choose what scrolling with 2 fingers, 3 fingers, etc does

Greetings. I started this thread becaue I thought that my trackpad and buttons were having driver issues. Turns out that I inadvertantly disconnected the associated cable during a RAM install. My appologies for being a silly-billy. I sincerely appreciate the responses on this thread.

I did learn a ton about drivers in general, there types for the G752VL running newer chips, where to find them, the various way in which to install them, etc...

The IC2HID error that I was getting ( "This device cannot start. (Code 10) A request for the HID descriptor failed." ) was because the cable located under the keyboard was not connected. Once I found the problem and re-connected it, the exclaimation point under IC2HID in Device Manager went away. I proptly deleted all of the drivers that I had tried and installed the SmartGuesture V4.0.17 driver found at and everything - absoutely all functions the smart gesture feature offers - work flawlessly. I am an ass.

Thank you again if you replied previously with help.

ASUS G752VL -- i7 6700HQ -- GTX 965M -- 64GB DDR4 -- Windows 10 64 bit -- Editing Platform