cancel
Showing results for 
Search instead for 
Did you mean: 

G751jy Temperature almost the same after changing thermal paste

Cannon_19
Level 9
I haven't changed the thermal paste in my rog g751jy in 2 years so I did it yesterday. I also cleaned all the dust. Before doing it, while playing Battlefield 1 my gpu was constantly at 86-87 degrees celsius and throttling, while cpu was around 92-97, with clock speeds bouncing between 3GHz and 3.3GHz, also reaching 3.4GHz sometimes. Fan speeds were around 3000rpm for gpu and 3300rpm for the cpu. After I was done with the paste and cleaning, I ran Battlefield 1 again and gpu never went above 75-76 degrees and was always at full speed. CPU however, runs at 3.4GHz all the time, and then it gets to 92 degrees and drops to 2.5GHz and ~83 degrees, and then goes back to 3.4GHz until it's at 92 degrees and it's a never ending cycle. Fan speeds were 3000rpm for the gpu and 3000rpm for the cpu (300rpm less than before for cpu). Idle temperatures are 40 degrees for the gpu and 45 degrees for cpu. Is this a normal result? I'm happy with the gpu results, but underwhelmed with cpu results. It never fell to 2.5GHz before, and why are the fans running 300rpm slower? Did I do something wrong? Any way to fix this? The thermal paste I used was Thermal Grizzly Kryonaut and Arctic thermal pads for the vram and vrm (0.5mm and 1mm). I spread the paste with included spatula, as recommended by thermal grizzly. Is there maybe a curing time for the paste or something?

Here are the pictures:
Before cleaning:



GPU:



After cleaning (I cleaned the vram and vrms too but didn't take a picture):

CPU:



GPU:



New paste and thermal pads:

Thermal pads on the heatsink:



GPU:



CPU:

453 Views
34 REPLIES 34

Cannon.19 wrote:
Thank you, that one works great! Why is there no manual control slider though? With the other profile I could set the fans to 100% myself regardless of temperature. Would it be possible with this one too?
EDIT: Actually I can't do it with old profile now either, I messed something up didn't I 😛


Yep, it's possible from the main GUI of NBFC, once you click on Enabled

85534

Make sure that NbfcService is running in Windows Services, I suggest you to set it on Automatic startup. This will start only the service, doesn't mean that NBFC is controlling your fans; if you disable it from the GUI it will stay off 😉

andreacos92 wrote:
Yep, it's possible from the main GUI of NBFC, once you click on Enabled

85534

Make sure that NbfcService is running in Windows Services, I suggest you to set it on Automatic startup. This will start only the service, doesn't mean that NBFC is controlling your fans; if you disable it from the GUI it will stay off 😉


Yeah it was bugged for some reason but it works now. I turned them both too 100% and damn, it sounds like a jet engine 😄 and temps went down drastically too.
But the laptop turned off after 3-4 minutes, no idea why.

Cannon.19 wrote:
Yeah it was bugged for some reason but it works now. I turned them both too 100% and damn, it sounds like a jet engine 😄 and temps went down drastically too.
But the laptop turned off after 3-4 minutes, no idea why.


If you put them to 100% manually through the sliders, my suggestion is to set them to 98% and not 100%, as I said before and like my config file. The speed is the same (it's in the maximum range/state) but it should avoid strange behaviour like sudden shutdowns.

Yes, at maximum speed it looks like it's ready to take off :cool: Probably the best compromise would be a middle ground between last and second-last speeds, but there aren't.

andreacos92 wrote:
If you put them to 100% manually through the sliders, my suggestion is to set them to 98% and not 100%, as I said before and like my config file. The speed is the same (it's in the maximum range/state) but it should avoid strange behaviour like sudden shutdowns.

Yes, at maximum speed it looks like it's ready to take off :cool: Probably the best compromise would be a middle ground between last and second-last speeds, but there aren't.


Alrighty, I'll try 98% then. And thank you for all the help mate, you've really helped a lot. I'd add to your rep, but it won't let me because I already did it recently 😄 .

Cannon.19 wrote:
Alrighty, I'll try 98% then. And thank you for all the help mate, you've really helped a lot. I'd add to your rep, but it won't let me because I already did it recently 😄 .


Ahahah thank you anyway!

And you're welcome, at a point I was feeling like this was my G751 😄