cancel
Showing results for 
Search instead for 
Did you mean: 

G751JT Won't boot - can flash with new bios and ctrl-home but still wont boot!

bmonty
Level 7
So I have been enjoying my G751JT until recently. It all started going wrong a few weeks ago when I began feeling extra paranoid and wanted to encrypt my machine. First thing was to find out about bitlocker, and that it wouldn't work as there is no TPM module. I thought I was buying a top machine but ....

So, after that I looked at veracrypt and thought it would work. Well .... first attempt failed because of secure boot. I thought I'd be able to add certificates but that's probably where the real problem started. I deleted the secure boot settings, tried running a github project which failed. I probably should have tried rebooting then, instead I tried again to begin the process to encrypt. This doesn't encrypt yet but sets a special bootloader.

Since then I have not been able to get into the bios / setup, see anything in the normal boot process.

After googling, I found some threads here that helped (https://rog.asus.com/forum/showthread.php?82687-bad-g751-bios-flash, https://rog.asus.com/forum/showthread.php?55497-G750jh-Bricked-Bios-after-update-solved) but didn't fix it yet.

I tried a winpe environment on a usb drive but no luck. I then tried the ctrl-home ezflash with bios downloaded from asus support. Ok, that works  - sort of. It installs and verifies and powers off but nothing after that. I have tried multiple times, with laptop display, vga and hdmi, all the same. The ezflash works Ok then blank screen. The usb key led does show about 5 seconds of activity and then nothing. Caps and num lock led's work. I have flashed with and without the hard drive installed - no difference.

I unplugged the battery and cmos - admittedly initially only for about 2 minutes and put stuff back together, with no change. I then left it all disconnected over night , same result. I tried with a Windows 7 dsic in the drive but that didn't make a difference.

Any ideas? Thanks.
2,670 Views
1 REPLY 1

Clintlgm
Level 14
Sounds like your hard drive is encrypted and you don't have access. BIOS has nothing to do with it hopefully you haven't damaged yours. Trash that hard drive and start over with a new one. Encryption of hard drives can be tricky. hopefully you backed up before starting such a major move.
G752VY-DH72 Win 10 Pro
512 GB M.2 Samsung 960 Pro
1 TB Samsung 850 pro 2.5 format
980m GTX 4 GB
32GB DDR 4 Standard RAM

Z97 PRO WiFi I7 4790K
Windows 10 Pro
Z97 -A
Windows 10 Pro