cancel
Showing results for 
Search instead for 
Did you mean: 

G751JT Internet Lag in all games.

AndreiZago28
Level 7
So I get internet lag in all games. (only on online games) And mostly CS GO and Dota 2.
Single Player games work fine.
Players around me look like they are teleporting, and I get taken back to what I was doing 1 second ago each minute. (Rubberband lag)
I have an ASUS Rog G751JT. I am using a wireless network, but I also get lag using a wired network.
I'm running Windows 8.1.
Can anyone help me?
Thanks.
16,761 Views
40 REPLIES 40

toronto699
Level 13

Come on man you are going to open a thread to ask about something on another thread then link to that thread?

You should know by now proper etiquette is to post on that thread (like you have already).

Splitting the conversation is not going to help find resolution, if anything it will hinder it after garnering a tiny bit of extra attention.

My advice is to close this thread.

i had problems only while playing on wifi and i fixed it by searching in google (problem was when the laptop connected to wifi and he still was searching for networks and that caused lagg spikes...

i suggest you to find the manufacture of your lan card and search google "lagg spikes / problems "name of the card" ... i found myself solution like this

I'm just trying to help someone with a problem because we could not find a solution for his issue , and I think I did the right thing thanks for your help and reply, most G751 owners do not read the hardware or software thread. thanks for your input and help

toronto699 wrote:
I'm just trying to help someone with a problem because we could not find a solution for his issue , and I think I did the right thing thanks for your help and reply, most G751 owners do not read the hardware or software thread. thanks for your input and help


Answered in your thread, you're welcome.

What do you think of this: http://forums.na.leagueoflegends.com/board/showthread.php?t=2957206&page=2
Should I do what is says?

AndreiZago28 wrote:
What do you think of this: http://forums.na.leagueoflegends.com/board/showthread.php?t=2957206&page=2
Should I do what is says?


I think you should follow my suggestion and Uninstall ROG Gamers First III and solve your problem. A Reboot will be required.

Asoryu wrote:
I think you should follow my suggestion and Uninstall ROG Gamers First III and solve your problem. A Reboot will be required.


Sorry, but I don't seem to have ROG Gamer First III installed.

AndreiZago28 wrote:
Sorry, but I don't seem to have ROG Gamer First III installed.


Rog Gamefirst III is what it should say under installed programs. If this the factory install, then you do have it.

Asoryu wrote:
Rog Gamefirst III is what it should say under installed programs. If this the factory install, then you do have it.

It's not the factory install.