cancel
Showing results for 
Search instead for 
Did you mean: 

G751JT-DB73 Third RMA Videos inside.

Duhef
Level 7
So I am currently on my third RMA for my G751JT-DB73. I have been struggling through Asus' horrible customer support for about 3 months now with no resolution. Apparently no one can properly receive information in the service center or even send out an email for my review.

I have been having major issues with the Intel AC-7260 wireless card in this model. It refuses to hold a stable connection and will constantly spike to high latency levels rendering a rubber band effect while playing any games. I have spent multiple hours of my own time attempting to remedy this issues and have had no luck. From driver updates to voodoo fixes from forums, nothing with stop this thing from spiking. Have other laptops in my home and one console that I have setup wirelessly due to the convenience and neither of these items have any issues. On top of that, there is a horrible crackle when any sound is played, typically happens whenever any sound is initialized and when the sounds is over, there is a pop. And lastly, backlight bleed on this model is the worst. I have never seen such bright yellow coming through such large surface areas of a panel.

So I sent it out for an RMA, the initial issues were for the above and it shipped with two broken keyboard keys. I know, that this point I'm regretting not returning it and just getting my money back. But the G-SYNC and all of the other hardware were such a great combination. The wireless card was replaced, keys fixed, and a "hinge" was replaced to fix the sound. Nothing was done about the backlight bleed but I wanted to see if the wireless was at least fixed. To my surprise, the first game I was able to play had problems. Spiking latency and rubber banding every 3 - 4 minutes. So it was time for a second RMA.

Second RMA was terrible. Laptop was at the facility for almost two weeks. I finally decided to follow up with Asus after the RMA status page said "repair in progress" with no changes made for days. They told me that the service center had sent me an email. Check all folders and what not and no email was found. Fought with them for the entire day, probably around 10 calls after constant disconnections, which I am chalking up to their poor phone infrastructure. I was directed to email someone that could get in contact with the service center and send pictures to them so they could further diagnose the issue because they "couldn't find anything wrong and the laptop is in excellent condition". I sent them a picture of me pining home with spikes over over 200ms. They said that is fine due to no packet loss, which is a joke of a response. They sent my laptop out that night without doing anything further.

So now we are on the third RMA and the same exact situation has happened. I had even sent videos and pictures to a CSS rep by the name of Jhamaica which I'm guessing she never forwarded to the repair team since the videos were too large to send to an email, she said I could upload them to youtube and give her a link. Well based off of the view count of one of the videos, no one but myself has watched the video. So I followed up with Asus, rep tells me that they sent me an email and they couldn't find anything wrong. It pains me to know that at this point, I'm going to be stuck with a near $2000 paperweight. I bought the unit to use it as a laptop, not have to hard wire ethernet wherever I go. At home, it's too much of a hassle and I don't "competitively" game so I am okay using wireless. Or on the off chance that I bring the laptop with me for travel or attend a LAN party (I'll never be too old for a LAN party) I will be stuck with this shoddy wireless card. It's really too bad that the wireless card is on the back of the mobo because I would have replaced it already but I don't want to void my warranty just yet.

Here are the links to the two videos. https://www.youtube.com/watch?v=FSw-l_Bic3U https://www.youtube.com/watch?v=hiq94qoL4CU
60 Views
0 REPLIES 0