Showing results for 
Search instead for 
Did you mean: 

g751jt Boot loop after BIOS update, but boots ok after exiting BIOS

Level 7
Hello. I did bunches of searching, but it seems like this is an issue with a lot of different symptom sets, and most seem to have slightly different solutions, so I decided it'd be better to make a new thread and try to compile recommendations for this particular case.

The machine is an ASUS ROG g751jt. I was running BIOS version 208 without experiencing this issue, and decided to update to the most recent in order to try to fix of the "machine stops while in sleep mode" issue. Flashing the BIOS went without a hitch, no errors or hangs or anything in particular. But, after the flash, on the reboot, the machine goes into a cycle of turning on the monitor (nothing displayed, no splash screen, just a black-but-active screen), holding for a couple of seconds, then shutting off and repeating the process until I go into the BIOS menu with F2. After I exit the BIOS menu, without making any changes, everything continues normally and I'm able to continue the boot process. This happens every time I restart, which is even more common than it used to be because the machine now shuts itself off *every* time I enter sleep mode, not just sometimes.

I have tried reflashing the same version with WinFlash, as well as using 210, and have the same symptoms. I plan to try 208 again, but it doesn't really seem like this is an issue with the BIOS itself--some of the threads I pulled up seem to indicate that this is hardware-related, although it's strange to me that an issue of that sort could be triggered by flashing the BIOS. Does anyone have any authoritative recommendations for this? Am I looking at wasting a few hours on a teardown to try to reseat everything (and hopefully not brick the machine in some way in the process), or is there an easier solution I'm overlooking? If I am staring that down, could anyone give me some information on *why* that would work, like what the root cause is that I'm fixing by poking around with the machine's innards?

ETA: If it matters, I flashed the BIOS from my main partition ("C:"), rather than from a USB or similar.

Level 7
Hello aawilson
I would suggest to send it for RMA if none of the method you tried has worked
Our engineers would sort this out for you, thank you.

Level 7
Would a purchase date in August 2015 still be in the RMA period? Regardless, this laptop is my daily use laptop and sending it in is extremely inconvenient, since I don't have a backup laptop just lying around. Is there some other option? If all you guys would be doing is replacing a part, then this could work in the same way a phone RMA works (you send the part, I send back the RMA'd piece), but I can see where your team wouldn't really want to do that if the part is expensive.

That is why I am reluctant to update the BIOS because of issues like these.:/ It's a good thing for you, though, that the company is willing to take a look at that for a free fix.:)

US Customer Loyalty Agent
If you're actually able to get into the bios after flashing, that's usually a good sign, but not sure why it isn't booting to your hard drive anymore.
If there was really something wrong with the motherboard or bios, assuming it would have just killed your unit so that you couldn't even get into the bios, and not convinced right now there is a hardware problem with the unit.

If you happen to be running Windows 7 (or linux) instead of the ASUS factory Win8 or Win10 image, let us know.

Not sure how worried you are about your hard drive and data (back-up first if necessary?), but assuming your not worried about it, try reloading your default bios settings if you haven't already and saving and exiting.
Re-enter the bios and make sure the notebook can recognize your hard drive at least and everything looks normal for the boot sequence.

If you have a way to reinstall Windows, consider trying that too on a different hard drive if available just to confirm it isn't a hard drive problem, but doesn't seem too likely your hard drive would go bad at the same time you flashed the bios.

Anyway, you may want to get more opinions (and back-up your data if necessary, but I'm probably being a little overcautious).
If you sent it back for repair, expect there is the possibility that repair will just erase your hard drive to reinstall Windows to solve it and just want to make sure you check that part on your end if you decide to send it in.

Good luck!

Level 7
Hey cl-Albert.

I should clarify that I am able to boot into the OS, but only after I enter the BIOS. That is, the normal boot sequence will not run, but everything is fine after I have entered the BIOS and exited it (with or without changes). Also, the laptop shipped with Windows 8, I upgraded it to Windows 10.

US Customer Loyalty Agent
Hi aawilson, thanks for the clarification and sorry for missing that earlier.

Yes, the problem is a little unusual and not sure what is causing it, but we may want to search for similar reports. Just want to remind you to reload the default bios settings after every bios flash and to save and exit if you haven't already.

I may change my mind about this later, but if you are okay with taking a chance on another bios flash, you may want to go back to the earlier 208 bios if you weren't seeing any problems with that version before. Worst case scenario is that the bios flash may just kill the system completely though if you are worried about this, but sounds like you have been able to flash the same bios version okay at least.
There is also a 211 bios posted on the G751JT download site if you didn't already notice, but if you're no longer under warranty, would prefer to avoid flashing the bios as much as possible in case it makes things worse (I may worry a bit too much as well).

Another idea is to either install a spare hard drive if available or erase your current hard drive if you prefer (after backing up) just to see if reinstalling Windows makes any difference which isn't obvious that it will right now.

Well, we may want to check around more for better suggestions if you can live with the problem a bit longer.

Level 7
A little update here (quite a bit later), but when I remove the optical drive, this problem disappears. Putting back the optical drive did not result in the behavior remanifesting, so the entire sequence was "remove optical drive, try boot and notice everything is fixed, put back optical drive, try boot and notice everything is still fixed, celebrate minorly". I am at the upgraded BIOS version (211).