Showing results for 
Search instead for 
Did you mean: 

G751JL Won't POST with TrackPad connected

Level 7
Hello, new forum member here (Long time ASUS fan though)

I finally got my hands on a G751JL ROG laptop this past week lightly used in excellent condition. The laptop worked absolutely flawlessly, however the fans were somewhat noisy, so I did what I usually do with my laptops. I disconnected the fans and removed the heatsink in order to replace the thermal paste and clean out the dust from the fans and heatsink. I finally put the laptop back together, and out of nowhere it stopped POSTing. The power LED is lit, as is the NUM lock, then it switches off after a few seconds. The screen and keyboard are black during this time. It's as if the laptop is stuck on something mid POST. Well, being technically minded I guessed I may have missed something when putting it back together, however nothing is damaged, I have examined all the cables and I even cleared CMOS by removing the battery for a while. However, I discovered the device POST's first time every time, IF and only if the ribbon cable to the trackpad is disconnected. The only way I can use this laptop at present, is if I perform that step, plug in the trackpad and reboot Windows. The trackpad works flawlessly, and rebooting does work. However if I turn the laptop off, the problems come back. I am absolutely lost as to what this could be, other than a firmware issue or something.


Laptop WILL NOT POST with the trackpad plugged in

I have tried:

-Unplugging and replugging connectors
-Reseating the motherboard
-Clearing CMOS
-Reflashing BIOS (It will not allow me to do this)
-Long pressing Power to reset the battery

Any suggestions/help/fixes would be of great value. I have found nothing else online that could explain this.