cancel
Showing results for 
Search instead for 
Did you mean: 

G751JL Missing Fast Boot in BIOS ?

nemerdekel
Level 7
I've noticed that the other versions of this notebook have a "fast boot' option in BIOS, mine does not have it, what's the deal with this? Asus forgot to put it in?
Laptop: G751JL
Processor: i7-4750HQ
Graphics Card: GTX 965M
Memory: 8 GB Samsung (stock)
Storage #1: Samsung 850 EVO 250gb
Storage #2: 1 TB 7200 rpm (stock)
OS: Windows 10 x64
538 Views
4 REPLIES 4

cdma2k
Level 7
are you in UEFI mode?

ROG_HARDCORE
Level 7
Turn off CSM, there you go.

Gps3dx
Level 12
nemerdekel wrote:
I've noticed that the other versions of this notebook have a "fast boot' option in BIOS, mine does not have it, what's the deal with this? Asus forgot to put it in?

Fastboot mode is a feature of UEFI "bios"... i.e the newest version that replaced the "legacy BIOS".
Your laptop model and many other have another feature in the UEFI bios to run the computer in "emulated" "legacy bios" by toggling CSM option (in the UEFI bios menus ) to ENABLED sate.
in that "CSM Enabled" state, you run as "legacy BIOS", thus you don't have the ability to use "Fast boot" mode, as it is a UEFI ( CSM DISABLED! ) feature.
Please refer to my guide about how to install windows properly that it will UEFI boot, so you'll be able to enjoy the many good feature of UEFI (and GPT for that matter ) - a link can be found in my sig, or just search for it as it is a sticky thread in this sub-forum.
Asus G751JT
Samsung EVO 850 120GB + 1TB HDD 7200RPM
Cleaned installed Win 10 HOME
My Guides:

  • [POST=538713]ROG LAPTOPS: COMPLETE DRIVER LIST ![/POST]
  • [POST=538713]How to install windows 8/8.1/10 on any UEFI supported laptop the PROPER way[/POST]
  • [POST=538711]HOW TO (EASILY!) UPGRADE FROM WIN7 SP1/8.1 WITHOUT GOING THROUGH THE UPGRADE PROCESS ITSELF ![/POST]
  • [POST=605307]HOW TO REMAP FN+KEY AND SPECIAL BUTTONS: "STEAM", "ROG" & "SHADOWPLAY"[/POST]
  • [POST=539663]Win 10 x64: SETUP USB @SUPERSPEED, NO HANG-UPS! | ACCELERATES USB 3.0/2.0 TRANSFER RATE SPEED TWICE![/POST]

nemerdekel
Level 7
I do have CSM turned off, and I installed it in UEFI mode following your guide (also every tool that I can verify it with tells me I indeed am in UEFI mode) that's why I found it strange and posted here
56537

It's not like my boot times are very slow, they take like 14 seconds, but i've seen the other versions of g751 boot in 8 so I was wondering what could be different in my case
Laptop: G751JL
Processor: i7-4750HQ
Graphics Card: GTX 965M
Memory: 8 GB Samsung (stock)
Storage #1: Samsung 850 EVO 250gb
Storage #2: 1 TB 7200 rpm (stock)
OS: Windows 10 x64