Showing results for 
Search instead for 
Did you mean: 

[G751JL] came here with one question ended up with two

Level 7
ok so i'm using said laptop in the title:

Screen Size 17.3 inches
Max Screen Resolution 1920*1080 pixels
Processor 2.6 GHz Core i7-4720HQ
Hard Drive 1024 GB HDD 7200 rpm
Graphics Coprocessor NVIDIA GTX965M 2GB GDDR5
Graphics Card Ram Size 2000 MB
Wireless Type 802.11 A/C
Number of USB 3.0 Ports 4
Average Battery Life (in hours) 3.5 hours

Other Technical Details
Brand Name Asus
Series ROG G751JL
Item model number G751JL-DS71
Operating System Windows 8.1
Item Weight 8.4 pounds
Item Dimensions L x W x H 12.50 x 16.40 x 0.90 inches
Color Black
Processor Brand Intel
Computer Memory Type DDR3 SDRAM
Hard Drive Rotational Speed 7200 RPM
Optical Drive Type DL DVD±RW/CD-RW
Batteries: 1 Lithium ion batteries required. (included)


(I believe i've found the answer to th efirst one after a while of more googling. I had to go into device manager, and under my
network adapter make sure nothing in there had the option to turn off the device to save power checked)

ok first off, no matter what i try, the laptop seems to halt/pause any activity such as downloads when i close the lid.
as far as i know know, i've configured all the power settings to have the computer do nothing when the lid is closed. i have no
idea if there are additional power settings or if there are ones specific to this model/maybe it's just something i'll have to live with.
even when it's plugged in it will still pause any activity, it's kinda inconvinient if i have any larger downloads, i'd rather just leave
and close the lid instead of hot-keying the display off. not to mention i cant even close the lid during any downloads period.
closing the lid does not sleep the comp, but it stops activity. its really weird.

problem number two. i was going to use the third party program, "speccy" to get my computer specifications. (i ended up
copy-pasting from the amazon web page i ordered it from). when i tried to use it, i got an error message and (as you can see in the
attachment below) it can't initiatiate the 'SPC dll'. does anyone know if this is an indicator of a larger underlying issue or problem?
i was kind of disappointed because i used to use this program quite a bit and now i think i'll have to find an alternative. but a lot
the fixes had people asking what their video cards and stuff and then there was stuff about BIOS so i was just wondering if
there was a bigger problem causing that program not to work.

anyways this is my first time purchasing a gaming computer/laptop so its going to take me a while to understand all these things.
any help is appreciated, thank.

Level 14
You'll probably have better luck with Hwinfo64 Sounds like you figured out the first. I haven't tried this with this computer but it could have something to do with cooling
G752VY-DH72 Win 10 Pro
512 GB M.2 Samsung 960 Pro
1 TB Samsung 850 pro 2.5 format
980m GTX 4 GB
32GB DDR 4 Standard RAM

Z97 PRO WiFi I7 4790K
Windows 10 Pro
Z97 -A
Windows 10 Pro