cancel
Showing results for 
Search instead for 
Did you mean: 

G751j Internet conection problems

Cayman
Level 7
Every time i try to conect to any web page o steam or whatever needs a internet conection
i cannot conect!!

ERR_CONECTION_TIME_OUT

i have 2 diferents laptops
the one with the problem is an asus G751j windows 10 (updated yesterday) before w10 i still have the same F*** problem
in w8.1

the other laptop its conected in the same router and dont have this problem

some games works from time to time bur 99% of the time the G751J its conected to internet but cannot navigate or get internet access

how do i solve this problem?
2,125 Views
2 REPLIES 2

Ausaar
Level 7
Cayman wrote:
Every time i try to conect to any web page o steam or whatever needs a internet conection
i cannot conect!!

ERR_CONECTION_TIME_OUT

i have 2 diferents laptops
the one with the problem is an asus G751j windows 10 (updated yesterday) before w10 i still have the same F*** problem
in w8.1

the other laptop its conected in the same router and dont have this problem

some games works from time to time bur 99% of the time the G751J its conected to internet but cannot navigate or get internet access

how do i solve this problem?


Hello, I had the same problem when I first used my G751JT.
I believe it was a problem with my antivirus and/or malware software. I had immediately uninstalled Mcafee when I first used the computer.
I also updated some drivers. I was then unable to download or connect to steam, etc. After a few days of trying stuff, I called Asus for support.
They recommended I restore everything to factory and do a reset.
This worked. I uninstalled mcafee with their tool this time and I am using Windows Defender along with a separate malware program.
I have not had any real problems since.

Hope this helps,
Jw

toronto699
Level 13
Try Uninstalling l Game First lll sometines it causes internet connection problems u can always reinstall it again .
http://www.asus.com/us/search/results.aspx?SearchKey=g751&searchType=Products&IsSupport=True