Showing results for 
Search instead for 
Did you mean: 

G751 touchpad - 1& 2 finger functionality issue

Level 7
Hello guys,

After a few months of not using my G751, when I booted it, I found the following issue:

The touchpad moves the cursor fine (without lag), but the 1-finger (e.g selection) and 2-finger functionality( e.g sliding) does not work.
I made sure, that all configurations in the ASUS SMART gesture panel are enabled.
What baffles me are the following:

1) The 3 and 4 finger functionality works perfectly.
2) When windows boots up, and Desktop icons have rendered, a random icon in Desktop is selected., e.g. a folder
3) I have dual boot Ubuntu. In Ubuntu, all touchpad functionalities work fine most of the time, but occasionally when I boot up Ubuntu, the touchpad is completely unresponsive.

Is it a hardware or a software issue? I tried installing the newest driver and reinstalled anew the ATK package. I also tried rollbacking to the previous (native driver). Nothing happened.

Is there anything I could try, software-wise? Or is it maybe a hardware issue?

Thanks in advance guys.