cancel
Showing results for 
Search instead for 
Did you mean: 

g751 JT Multiscreen freeze

guillaumea
Level 7
Hi,
i'm trying to use multi screen with a new g751 JT. When I use HDMI + mini display port with HMI adaptor, it works for 2s then windows freeze. If inside game, visuals still works but keyboard and mouse stops working so I have to press start button to reboot, unable to ctrl+alt+sup to have a look on what's happening.
Any ideas ?
thanks in advance

Guillaume
12,266 Views
18 REPLIES 18

hmscott
Level 12
guillaumea wrote:
Hi,
i'm trying to use multi screen with a new g751 JT. When I use HDMI + mini display port with HMI adaptor, it works for 2s then windows freeze. If inside game, visuals still works but keyboard and mouse stops working so I have to press start button to reboot, unable to ctrl+alt+sup to have a look on what's happening.
Any ideas ?
thanks in advance
Guillaume


Guillaume, do you have the desktop mirrored, extended, or independent? Try changing the desktop spanning to see if that helps. Try it with only built-in and one or the other, but not all 3 at once. See if you can isolate the problem to HDMI or DisplayPort + internal. Then try just the 2 external desktops.

It also might be the cabling, isolating each monitor combination will help determine if it is one external display or the other that is causing the problem, and swap the cabling between them to see if the problem moves with the cabling change.

Noone else has reported a freeze up with external monitors on the G751JT/JY, but this post talks about compatibility with new Nvidia drivers and their external configuration, so it might be related - you might try running the 344.80 Hotfix release

G751 HDMI Problem
http://rog.asus.com/forum/showthread.php?54604-G751-HDMI-Problem&p=456667&viewfull=1#post456667

GeForce Hotfix driver 344.80
https://nvidia.custhelp.com/app/answers/detail/a_id/3607/~/geforce-hotfix-driver-344.80

•GeForce GTX 980 displays texture shimmering when Texture Filtering Quality set to High Quality.
•GPU outputs fuzzy lines over DisplayPort after a period of time following driver updates.
==>> •System hang up and black screen after power on with some monitors (DP1.2 & 4K/60Hz) + GTX980

ROGscholar
Level 7
Interesting post. please keep update your test findings.

hi hmscott,
first thank you for your complete response.
My bad i didn't do the test before 😞
So after some tests, everything is fine with built-in + hdmi or vga.
The problem appears with the minidisplay adaptor to hdmi
With exteranl screen (iiyama prolite) it freeze really fast. When the external screen is sleeping, no problem but when it wake up, freezing appears.
Same with an old sony tvscreen but it takes more time (+-5s)
Tested with 344.80 and i got the same problem.
I also test with another minidisplay->hdmi adaptor and i got the same freezing.

Maybe something with a return signal from the screen ?

REALTORPDX
Level 7
Hi -- I'm having exactly this problem. A few seconds after I plug the mini-displayport adapter into the laptop (G751JT -- brand new as of today), the computer freezes and I have to hold the power button down for 5 seconds or so to force the computer to power down and then reboot. I've tried several cables and several external monitors, and they all cause this freeze. Connecting to the HDMI port on the laptop works fine, but the monitor I want to use doesn't support 2560x1440 over the HDMI port. Were you able to fix this issue?

Edit: I'm running latest (I think) NVidia drivers; 347.09. The monitor display is mirrored (the computer freezes before I have a chance to switch to extended, and setting it before hand doesn't seem to help). The signal continues to be output over the display port connection, but the computer is completely frozen (or at least the keyboard and mouse don't work). Any troubleshooting ideas?

geneticweapon
Level 7
The display port on these machines is jacked, there's been multiple complaints about it.

hmscott
Level 12
It looks like a widespread problem with some DisplayPort cables being the cause.

https://www.google.com/search?num=50&safe=off&q=displayport+screen+freezing&spell=1&sa=X&ei=W9unVI_K...

I ordered these and both work fine. I used the long cable with mini DisplayPort mostly, but used the mini DisplayPort Adapter cable with a DisplayPort-DisplayPort cable as well on my G750JX/JH:

Accell B143B-007J UltraAV Mini DisplayPort to DisplayPort 1.2 Cable with Latch, White, 6.6-Feet
http://www.amazon.com/gp/product/B00A7R9I22/ref=oh_aui_detailpage_o06_s00?ie=UTF8&psc=1

Accell B112B-001B 10-Inch UltraAV Mini DisplayPort/DisplayPort Female Adapter - Black
http://www.amazon.com/gp/product/B003TSDG06/ref=oh_aui_detailpage_o06_s00?ie=UTF8&psc=1

No freezing, I use independent desktops, not spanning or mirror, FYI.

REALTORPDX
Level 7
Hi -- thanks for the suggestions, and particularly for the amazon links for specific products you know work with your setup! Hopefully this is just a driver issue that can be eventually fixed. I just ordered the Accell cable and will post on Monday when I get it with an update. Just for completeness: I'm trying to connect to a Dell U2713HM at 2560x1440, although I also tried plugging into an Asus VS248 at 1920x1080 with the same result.

REALTORPDX
Level 7
An update -- received the Accell cable and everything now works fine. Must have been the same issue others were reporting where there is some bug interfacing with certain cables somewhere. Thanks for your help!

REALTORPDX wrote:
An update -- received the Accell cable and everything now works fine. Must have been the same issue others were reporting where there is some bug interfacing with certain cables somewhere. Thanks for your help!


REALTORPDX, the cables turn out to be the weak link in the DP world. I found that out the hard way early on with Dell cables, and things haven't changed.

Glad to hear it works, and I hope others read this and get a good cable if they can't get their DisplayPort to work. 🙂