cancel
Showing results for 
Search instead for 
Did you mean: 

G751 Imbalanced Sound Problem (internal speakers only), FIX IS OUT!

Jlieu
Level 7
http://support.asus.com/Download.aspx?SLanguage=en&m=Audio&os=30

download the latest Version V6.0.1.7427

No new UI as promised. lol

Edit by cl-Albert: Hope it's okay to edit your post Jlieu, but anybody that wants to read more about the original problem and gory history of this issue may want to check this post below which is currently closed while we check out this new *.7432 G751 audio driver version at this post. Thanks.

G751 Imbalanced Sound Problem OFFICIAL SUPPORT THREAD
https://rog.asus.com/forum/showthread.php?54313-G751-Imbalanced-Sound-Problem-OFFICIAL-SUPPORT-THREA...
306,548 Views
412 REPLIES 412

Jlieu
Level 7
http://www.asus.com/Notebooks_Ultrabooks/ASUS_ROG_G751JT/HelpDesk_Download/

official version. should include new UI. test now.

NitroX
Level 10
I'm now testing the 7432 drivers . It seems that they are working well but I don't have the Asus AudioWizard anymore because I have made a clean install of the drivers. You can now test these drivers by right clicking on "Sound Icon" in the task bar, selecting "Playback Devices" --> Speakers ---> Properties --> Levels and set the front level to 0 and leave Internal Subwoofer at 50. You will now hear only the low frequencies from the subwoofer. Place the Internal Subwoofer slide between 50-80. At 100 the palm rest starts vibrating.

Anyone has the AudioWizard along with these drivers ?

New drivers here, at AUDIO: http://www.asus.com/Notebooks_Ultrabooks/ASUS_ROG_G751JY/HelpDesk_Download/

Later EDIT: Sorry for the typo! I wanted to write 7432 drivers instead of 7437. I've corrected after!

NitroX wrote:
I'm now testing the 7432 drivers . It seems that they are working well but I don't have the Asus AudioWizard anymore because I have made a clean install of the drivers. You can now test these drivers by right clicking on "Sound Icon" in the task bar, selecting "Playback Devices" --> Speakers ---> Properties --> Levels and set the front level to 0 and leave Internal Subwoofer at 50. You will now hear only the low frequencies from the subwoofer. Place the Internal Subwoofer slide between 50-80. At 100 the palm rest starts vibrating.

Anyone has the AudioWizard along with these drivers ?

New drivers here, at AUDIO: http://www.asus.com/Notebooks_Ultrabooks/ASUS_ROG_G751JY/HelpDesk_Download/


NitroX, here in the US that link (JY) is only showing .7335, not 7427 or 7432, and the JT site is the same, until the sites sync up inside Asus, please post a direct download link to the latest audio driver package with a version number, so it can be downloaded directly.

46260


Update: Thanks to Edweird in the other (now closed) thread for this direct link to the 7432 driver:

http://dlcdnet.asus.com/pub/ASUS/nb/DriversForWin8.1/Audio/Audio_Realtek_Win81_64_VER6017432.zip

Update2: The new 7432 driver is showing up in the G751 support areas now from the US, at least for me 🙂

cl-Albert
US Customer Loyalty Agent
hmscott wrote:
NitroX, here in the US that link is only showing .7335, not 7427 or 7437, until the sites sync up inside Asus, please post a direct download link to the latest audio driver package with a version number, so it can be downloaded directly.


Thanks for checking hmscott.
Looks like the new audio driver may only be available on the G751JY downloads right now at NitroX's link above, so anybody that is interested may need to get it from that page, but the direct link is below too.

G751JY Realtek Audio Driver Version V6.0.1.7432
File Size 200.21 MB

http://dlcdnet.asus.com/pub/ASUS/nb/DriversForWin8.1/Audio/Audio_Realtek_Win81_64_VER6017432.zip

Edit 2/6/15: The *.7432 audio driver can now be found under the G751JT downloads too.

NitroX wrote:
I'm now testing the 7437 drivers . It seems that they are working well but I don't have the Asus AudioWizard anymore because I have made a clean install of the drivers. You can now test these drivers by right clicking on "Sound Icon" in the task bar, selecting "Playback Devices" --> Speakers ---> Properties --> Levels and set the front level to 0 and leave Internal Subwoofer at 50. You will now hear only the low frequencies from the subwoofer. Place the Internal Subwoofer slide between 50-80. At 100 the palm rest starts vibrating.

Anyone has the AudioWizard along with these drivers ?

New drivers here, at AUDIO: http://www.asus.com/Notebooks_Ultrabooks/ASUS_ROG_G751JY/HelpDesk_Download/


NitroX, everyone is only seeing version 7432, is your mention of testing 7437 a typo, or did you find a newer version somewhere else?

Update: NitroX confirmed it was a typo, driver is 7432 only.

hmscott wrote:
NitroX, everyone is only seeing version 7432, is your mention of testing 7437 a typo, or did you find a newer version somewhere else?

Update: NitroX confirmed it was a typo, driver is 7432 only.


It was a typo. I'm sorry if I've put anyone on a driver hunt because of this 😛 . I am running 7432 and these drivers are great. I listened to the laptop speakers all day long 😄 .

EDIT: Btw, how are u guys liking the 5.1 setting for the laptop speakers when on 5.1 the sound is still imbalanced and the subwoofer plays all frequencies ? Please someone try the 5.1 and tell me that it also happens to them and I'm not the only one with this issue.

On Stereo the laptop speakers are working just fine.

NitroX wrote:
I'm now testing the 7432 drivers . It seems that they are working well but I don't have the Asus AudioWizard anymore because I have made a clean install of the drivers. You can now test these drivers by right clicking on "Sound Icon" in the task bar, selecting "Playback Devices" --> Speakers ---> Properties --> Levels and set the front level to 0 and leave Internal Subwoofer at 50. You will now hear only the low frequencies from the subwoofer. Place the Internal Subwoofer slide between 50-80. At 100 the palm rest starts vibrating.

Anyone has the AudioWizard along with these drivers ?

New drivers here, at AUDIO: http://www.asus.com/Notebooks_Ultrabooks/ASUS_ROG_G751JY/HelpDesk_Download/

Later EDIT: Sorry for the typo! I wanted to write 7432 drivers instead of 7437. I've corrected after!


yeah - I have the same problem - audio wizard disappeared after I instaled the new drivers.

Paco wrote:
yeah - I have the same problem - audio wizard disappeared after I instaled the new drivers.


I have posted the reason in a later post :P. You have to follow the instructions of the setup just as they come, so firstly you click on the setup and when the setup asks to restart just press ok (this is the part were the setup uninstalls the old drivers). After the restart the setup will continue and it will ask you again for a restart after it finishes. Again you must click ok when it asks you (don't go for a later reboot). Now this was the part were the new driver has been installed on to your system. After the 2nd restart the AudioWizard will also pop-out on your desktop.

Enjoy the new drivers at their full capacity ! Without Audiowizard, the stereo mode for laptop speakers is quite poor.

NitroX wrote:
I have posted the reason in a later post :P. You have to follow the instructions of the setup just as they come, so firstly you click on the setup and when the setup asks to restart just press ok (this is the part were the setup uninstalls the old drivers). After the restart the setup will continue and it will ask you again for a restart after it finishes. Again you must click ok when it asks you (don't go for a later reboot). Now this was the part were the new driver has been installed on to your system. After the 2nd restart the AudioWizard will also pop-out on your desktop.

Enjoy the new drivers at their full capacity ! Without Audiowizard, the stereo mode for laptop speakers is quite poor.


did everything like you said ...... and still no Audio Wizard.