cancel
Showing results for 
Search instead for 
Did you mean: 

G750JX - Win 10 x64 - Thunderbolt

corylee
Level 7
Hi everybody,

I have G750JX ROG notebook and Win 10 x64.

I was going to start using the Thunderbolt and plug audio interface via this port, but I found that nothing happened then. I looked through and didn't find Thunderbolt in device manager.

Eventually I rebooted the system, found Thunderbolt in BIOS and change the security level to Debug Mode and after that new system device is appeared in the Device Manager, but there is no driver can be found for this device. I see error with code 28.

I tried to find the driver manually via device ID:
PCI\VEN_8086&DEV_1548&SUBSYS_11112222&REV_03

but I found nothing.

I believe we're talking about Thunderbolt version 1.

Please advice. What should I do? How can I start using Thunderbolt in Win 10 x64? Where to find/get the driver? I was very surprised that this port is not working by default.

Thanks in advance.
2,687 Views
5 REPLIES 5

jdfrench3
Level 12
The Asus G750JX is five years old. I believe the G750JX Thunderbolt port was optional. The G750JM Thunderbolt port was available on some models. You could look in the G750JM ASUS Download Center for its' driver.

You could also download the Intel Driver and Support Assistant software and see if it can properly detect the need for the Thunderbolt driver.

https://downloadcenter.intel.com/download/28425/Intel-Driver-Support-Assistant

I suspect your motherboard doesn't have the Thunderbolt port activated and is not functional.

Good Luck
G752VSK, G75VW-3D, G51J, G1S
Homebuilt Windows Server

Thanks, I installed the mentioned software, but I do not see Thunderbolt.

When I search by VEN then I see the name of the device:
Intel Corporation DSL3310 Thunderbolt Controller [Cactus Ridge 2C 2012]

Thus, we're talking about this controller:
https://ark.intel.com/content/www/ru/ru/ark/products/67022/intel-dsl3310-thunderbolt-controller.html

But there is no drivers on this page.

Eventually, I still have no idea where to find the driver(((

Download from this German site:

https://www.asustreiber.de/downloads/download/51-windows-8-1/652-g750jm-treiber-dvd

It represents a Windows 8.1 DVD set but I downloaded/mounted it and found the Thunderbolt driver in the following subfolder:

G750JM_81_64_5.01/Software/Others/Intel/Thunderbolt/W7_64_8_64_81_64_1.4.0.1/Thunderbolt.exe

You wanted the driver, there it is.

Let me know how it works out.

Good Luck
G752VSK, G75VW-3D, G51J, G1S
Homebuilt Windows Server

Thanks. Unfortunately this solution doesn't work. I tried it earlier. I had talked to ASUS customer support. Device manager still displays the same error and there are no drivers found. Installed software doesn't see the audio interface after connecting as well.

Blake1
Level 10
Hello corylee,
Please PM me the product SN.
Also, may I know if your DisplayPort is working fine?
Thank you.