cancel
Showing results for 
Search instead for 
Did you mean: 

G750JW touch pad issue with anti-virus software that I resolved

Wallinator
Level 7
Hi There

I would like to share this so others do not have to take the same journey I did.

I bought a new G750JW from a vendor awhile ago (vendor does not matter) that came with windows 8 installed. I upgraded to windows 8.1 with no issues and started building my system.

- Upgraded the Nvidia drivers
- Updated the chipset drivers
- Update the component drivers from the Asus support site. (ATK,hotkey Utils)
- installed an antivirus software

And then after a while (couple of days) the touch pad stopped working.

I then:
-Checked device manager and it was not listed
- Disabled and re-enabled in the BIOS and it still wouldn't show up.
- started uninstalling devices and re-installing them to resolve ay conflicts (There was none)

I finally bit the bullet and sent it back to Asus for warranty. After a week or so I got it back. The image was reinstalled to factory and my touch pad was working again. so I...

- Upgraded the Nvidia drivers
- Updated the chipset drivers
- Update the component drivers from the Asus support site.(ATK,hotkey Utils)
- installed an antivirus software

and the touch pad failed again...

I did all the same trouble shooting as before.. tried booting of a OS cd to see if the touch pad worked then (bypassing the hard drive OS) and it didn't so I contacted Asus again (by Phone this time) and they were quite helpful. We decided to try another OS wipe but I declined to do it right away. After I got off the call I decided to check the event log and saw this obscure error:

The (antivirius software) HardwareID service failed to start due to the following error:
Tye specified procedure could not be found.

I then went hmmmmm....

I proceeded to uninstalled the antivirus software and on a reboot voila! my touch pad came back.

Just thought I would share this as this was a very lengthy journey to resolve this as the touch pad would not even show in the Device Manager till I uninstalled the antivirus software.

I will not list the name of the software as I don't want to bash them(this is the first issue I have had and there software is good) but if you see this error in your event log and your touch pad has failed its a good indication that is the issue.

Note: Antivirus software is important so do this AT YOUR OWN RISK. this is informative and nothing else.

This is just one of them obscure, moon is full, kinda things.. P**P happens

Regards,

Wall
6,275 Views
6 REPLIES 6

hmscott
Level 12
Wall, nice debugging, but you should list the software, since it does conflict with our specific hardware/software/windows integration in the G750... whether it is their fault or not, if it is to be avoided till they fix it, it would be nice to know - would save us the same or other problems on our G750's.

There have been people with unresolved touchpad oddness, and I don't recall anyone mention trying to remove anti-virus software, or even mentioning what anti-virus they have installed... it might just be that was their problem too.

I uninstalled the McAfee software that came with the G750JH, and installed Norton Internet Security, and so far I haven't had any problems, if you are looking for a replacement.

Thanks Wall!

Wallinator
Level 7
Hi hmscott
The software was avast home

Regards

Wall

Wallinator
Level 7
This is the eventlog error

Log Name: System
Source: Service Control Manager
Date: 6/10/2014 11:28:39 AM
Event ID: 7000
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: xxxxxxx
Description:
The avast! HardwareID service failed to start due to the following error:
The specified procedure could not be found.
Event Xml:



7000
0
2
0
0
0x8080000000000000

1467


System
xxxxxxxxxx



avast! HardwareID
%%127
61007300770048007700690064000000

hmscott
Level 12
Wall, that avast! eventlog error looks like just a startup failure for the avast! service... and that is what caused the touchpad to stop working? And, after uninstalling avast! you didn't have any touchpad issues?

If you paid for avast!, you should ask for a refund from avast!, and send them the debugging information. They might ask to debug a solution with you, but you might get your $ back in the end.

Hi HMSCOTT

It was avast home free and yes when I uninstalled it my touch pad started working again.

I have not had the issue since and I am now running Trend Micro.

Regards

Wall

Wallinator
Level 7
This has happened again ..Ugh. WTF Asus its a touch pad! With all the threads about this issue can't you get in contact with Elantech and get this resolved? Now I gotta sift through the eventlog to see what friggin software I installed is blocking the touchpad again. Very dissapointed in this product!