cancel
Showing results for 
Search instead for 
Did you mean: 

G750JS sound problem - speakers/subwoofer don't work together?

Stiglar
Level 7
Just purchased the laptop a few days ago, installed win, drivers, all needed.

My speakers and subwoofer work independently. The mixer gives me the option to pick 2 "sets of speakers" . One is for the subwoofer and the other is for the speakers, but I can't make them work together/in the same time no matter what I try.

Also...didn't find maxxaudio stuff on my laptop.

Don't know how to fix this problem with the speakers/subwoofer.

Thanks.
6,547 Views
7 REPLIES 7

Hacktivator
Level 7
I also have a problem with my G750JS subwoofer. I think it doesn't work properly. I don't feel any bass power coming from my laptop and if I increase the bass level from maxxaudio software, still, no major change in sound output. Though the sounds come more "thick" and "clogged", I don't hear the bass power. Another bigger problem is the fact that sometimes when playing a bass predominant song, I hear a little "scratch" and the almost inaudible bass feature disappears altogether.

What is it to be done? I have the latest drivers. Please respond ASUS asap.

Prostar_Compute
Level 9
My speakers and subwoofer work independently. The mixer gives me the option to pick 2 "sets of speakers" . One is for the subwoofer and the other is for the speakers, but I can't make them work together/in the same time no matter what I try.


One thing to remember is that it is not a true 2.1 setup. The "subwoofer" is another speaker with a low-pass filter. It is not a "dedicated" woofer.

That said: What do you mean you can't get them to work together? All output directed to the speakers by default should be emitted by them all. 😞

I also have a problem with my G750JS subwoofer. I think it doesn't work properly. I don't feel any bass power coming from my laptop and if I increase the bass level from maxxaudio software, still, no major change in sound output. Though the sounds come more "thick" and "clogged", I don't hear the bass power. Another bigger problem is the fact that sometimes when playing a bass predominant song, I hear a little "scratch" and the almost inaudible bass feature disappears altogether.


Your case almost sounds like a defective or blown speaker. You may actually need to contact Asus directly for assistance or a RMA.

We customize Asus, MSI, and Clevo laptops!

I see....I still can't fix it by myself...maybe it's defective indeed. Could you please direct me to ASUS assistance?

I'm having the same problem, I'm hoping its the driver and not the actual speakers. Any info on how to fix this besides sending back the laptop. I would like to avoid sending it back to ASUS.

PapiChuloNica wrote:
I'm having the same problem, I'm hoping its the driver and not the actual speakers. Any info on how to fix this besides sending back the laptop. I would like to avoid sending it back to ASUS.


Do you have the MaxxAudio settings available? If not, then your driver does not .... well ... drive the subwoofer.

If you asked me, I would have said I do have the MaxxAudio settings available...and it still sounds like a broken subwoofer...or doesn't sound at all.

singkitfjrm
Level 7
Any luck if anyone able to fix the subwoofer WITHOUT sending it back to ASUS?