Showing results for 
Search instead for 
Did you mean: 

G74SX processor upgrade to i7-3740QM not working?

Level 7

I've read-up on i7 processors that fit the G2 Socket in the G74SX running at 45W and as the best cost/performance combination want to upgrade to an i7-3740QM.
I understand that the G74SX bios currently only supports those with the CPUID's 206A6 and 206A7 and so not the 3740QM.
The i7-3740QM has a CPUID of 306A9 and I obtained the latest microcode for it and upgrades for the A6 and A7 microcode files from the Intel website.

Using Mmtool I upgraded the bios microcode for A6 and A7 and add the CPUID 306A9 microcode to support the 3740QM processor.
I ordered the microcode from A9 to A6 (highest to lowest) in the bios just in case the sequence was relevant.

Whilst I was modding the bios I used AMIBCP4.53 to update it to allow AES256 encryption and made available hidden menu items such as access to the PROCHOT# in case it was needed.
I then flashed the custom BIOS (I numbered it 204) to my laptop.

Immediately I found my existing 2630QM processor performance improved with none of the throttling I had previously experienced and removing the need for me to employ disabling of the PROCHOT#.
Also there is an unexpected improvement in the graphics performance with the 560M 3Gig with auto-setup of graphics in the Company of Heroes game I've recently been playing is now offering better graphics options than before and at a higher frame rate.
Yet the only change I noted in the CPU-ID and HWinfo64 reports is an increased PCIe version from 1.5 to 2.0.

I assumed therefore that the BIOS upgrade was successful and purchased a 3740QM to try.
On installation of the 3740QM, the G74SX spins up the hard drives and the keyboard lights up, but then the keyboard lights go out after a few seconds and laptop remains powered on but the display doesn't show anything during the entire startup process.
As I'd read elsewhere, I removed the CMOS battery and pressed the power button for a few second to clear it thinking the BIOS settings need to be removed.
Just in case I also left the CMOS battery out overnight.
As I'd also read the power supply might not be providing enough power for newer processors, even though the same 45W consumption, I lowered the power requirements by installing only one SSD and one memory stick.
None of this worked and this leaves me to suspect there is something I've missed in my understanding of how BIOS's work or the processor I purchased is a dud.

I refitted my 2630QM processor and the laptop is functioning normally again and I'm submitting this new thread from it.

Any advice on why the 3740QM processor doesn't work in my G74SX with an updated BIOS, would be greatly appreciated.



Level 12
What you're trying to do would most likely work with certain desktop boards for such an upgrade. However, most of the time with notebooks, especially ASUS models, their SKUs are usually the highest you can do within the same CPU architecture, even despite having done the microcode update yourself.

Now clearing the CMOS with ASUS notebooks does not act the same way as it does with desktops. The most that will happen is the date/time will be reset, no BIOS settings will actually default. In this regard with ASUS notebooks, settings changed in the BIOS are not saved into SRAM (why CMOS reset doesn't work) but written to a module in EEPROM (NVRAM). This is also why a lot of ASUS notebooks are in RMA after some settings already saved are being corrupted with being overwritten again and the boot and recovery blocks are then no longer accessible, rendering the notebook with no keyboard lights or even recognize any key commands (requiring hardware programmer to resolve). ASUS has limited a lot of features and user control within the BIOS and their MB PCB design/Chipset (supporting) that allows for anything outside their models/SKUs.

It is not the power supply unable to provide the TDP of the CPU, but rather, it's the aforementioned above unfortunately.

Some people have gone from 45W 3610/30QM CPUs in a G75 to a 3940XM which is TDP 55W without issues except for Turbo Boost clocks fluctuating a lot (varies with each system if not at all in some). Even if Sandy Bridge and Ivy Bridge are backwards compatible, it's unlikely to be successful upgrade with ASUS notebooks (specifically) just by a drop-in upgrade.

This kind of makes sense now, but the iGPU has been disabled using certain modules/callbacks in most of ASUS G-series notebooks. So the fact your system stays powered up with a black screen and doesn't shut down right away tells me you need the correct PEI/DXE modules from a G75 system BIOS perhaps (with experimentation) since it's most likely initiating the internal graphics of your 3740QM where the BIOS has limited this control for Sandy Bridge CPUs, therefore conflicts regarding which has first VBIOS boot priority is undetermined.

Hopefully this helps answer some of your questions.

Level 13
Interesting take. When I was experimenting trying to max out the memory on my G752VY and made changes with XTU and it bricked pulling the CMOS battery is precisely how I was able to get it to work again. Nothing else worked so while it may not default all the BIOS settings it does do more than reset the clock.

“Two things are infinite: the universe and human stupidity, I'm not sure about the former” ~ Albert Einstein

Level 12
Why not try shunting JRST2001 for the reset instead of pulling the battery. It should effectively do the same thing. I may have forgotten that memory values were reset as well since you've mentioned this before too. However, most critical settings do not default, that was my point.