cancel
Showing results for 
Search instead for 
Did you mean: 

G74Sx Fresco Logic USB3 Host Controller is not found! [solved?]

XZ3R0
Level 7
Been searching the internet and these forums for days now. Can't seem to find a solution to this problem.

Model: G74Sx-DH73-3D
I just did a fresh install, first thing I did was install chipset drivers but now I can't get my USB 3.0 port working and when I try to install the host controller i get "Fresco Logic USB3 Host Controller is not found!"

I seem to have a bunch of usb controllers in device manager (i feel like too many?)
Anyone know what to do here?


43,274 Views
14 REPLIES 14

Chino
Level 15

XZ3R0
Level 7
Opps, G74Sx-DH73-3D

Chino
Level 15
Are you downloading the driver from the Asus website or from another site? And is your Windows 32Bit or 64Bit?

Chino wrote:
Are you downloading the driver from the Asus website or from another site? And is your Windows 32Bit or 64Bit?

Ive tried the ones off the ASUS site that are listed for my laptop and i have tried newer ones as well. same outcome.
Windows 7 64bit.

It's like it doesn't know it exists. Plugging something into the port does absolutely nothing as well. Working fine before reformat.

cl-Albert
US Customer Loyalty Agent
XZ3R0 wrote:
Ive tried the ones off the ASUS site that are listed for my laptop and i have tried newer ones as well. same outcome.
Windows 7 64bit.

It's like it doesn't know it exists. Plugging something into the port does absolutely nothing as well. Working fine before reformat.


Sounds like there should be some kind of software issue (?), but not sure what the problem is.

1. Did you install the Intel Chipset/INF and ATK driver and did they seem to install okay?

2. Whenever I run into strange software issues, it often seems related to the .Net framework software, so you might also try installing all the important Windows updates and checking your .Net framework version?

I don't know how device manager will look if that USB 3.0 driver is not installed, so hopefully we can get more information and help from other G74Sx owners.

Also, I wonder if it's normal that the USB 3.0 port doesn't work at all when the USB 3.0 driver isn't installed.

cl-Albert wrote:
Sounds like there should be some kind of software issue (?), but not sure what the problem is.

1. Did you install the Intel Chipset/INF and ATK driver and did they seem to install okay?

2. Whenever I run into strange software issues, it often seems related to the .Net framework software, so you might also try installing all the important Windows updates and checking your .Net framework version?

I don't know how device manager will look if that USB 3.0 driver is not installed, so hopefully we can get more information and help from other G74Sx owners.

Also, I wonder if it's normal that the USB 3.0 port doesn't work at all when the USB 3.0 driver isn't installed.


Yes, everything has,and continues to install fine. I have no issues besides this. Thinking about reformatting again but i just got everything setup and I really rather not just cause of ONE thing.
I have installed all Windows updates (including .net 4.5 framework)

Pitcher1
Level 9
what OS version do you install? win 7 or win 8? ASUS have not provide Win 8 driver.

Chino
Level 15
Are there any "unknown device" entries in Hardware Manager? And have you tried plugging a pendrive into the USB 3.0 port to see if it's working?

Chino wrote:
Are there any "unknown device" entries in Hardware Manager? And have you tried plugging a pendrive into the USB 3.0 port to see if it's working?

No there isn't. [see photo in first post]
Yes, several [see last reply]

Edit: i will add, it powers up an external hdd, but obviously i don't get any notification about a new device or see it in explorer or etc.