Showing results for 
Search instead for 
Did you mean: 

G74sx and drivers. (crashes)

Not applicable
Hi. Saw a thread the other day where one guy had problems with his g74sx
had its "explorer not responding" I had the same problems. so I tought it
was my SSD that was the problem.
So Ive been in with contact with corsair trying to get help, so first of all
im going to try it on my desktop soon.

But when I saw that thread I started to think, what if it's not the SSD?
What if its the drivers that is causing the problems on a G74sx.

I solved my "explorer not responding" with reinstalling + new drivers.
But my laptop is still unstable as hell.

It works fine to games most of the times. But It really wants to freeze sometimes.
Like when using internet explorer/steam somtimes. and other programs.
And when it freezes, either its "almost" dead, I try ctrl alt del but the activity window wont show up. It just says something like, loading secure options or something.
But nothing happens. So I reboot.

OR they system dies instant, so only way is to reboot.

Its quite annoying. But im there soon.

Maybe I should try reinstalling IE? or try Firefox.

Some new drivers might fix all these problems maybe.
But will take some time I guess.

Im not saying that it is this way, will try it on my desktop in some days.
and then I will know for sure.


Not applicable
oh well. I turned it off instead 😛 hehe.

So now im just waiting for it to happen 😛

Not applicable
zzz. Computer is still crashing(freezing).
Gonna throw it out the window soon. More fun that way. *RAAAAAGEEEE*
I just hate computers, they never work as you want them to.

also when the computer froze, the ATK drivers got fucked again. so the backelit+hotkeys isnt working atm.

Bummer 😞

Well, as I mentioned I would try to disable everything you possibly can and see if it still has problems. Did you already look in the Windows Event log to see if anything is indicated there?
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

Not applicable
Actually, one time when it froze there was no indicator what went wrong.
and another time the only thing I found was this

"The device \ Device \ Ide \ iaStor0 has not responded within the specified time limit. "
And I almost 100% sure that this made my computer freeze ONCE

Not applicable
What does it mean when the computer crashes and you cant find any information what happend?
Happend again, so checked all logs in that time range. BUT, didnt find anything usefull at all.

Level 10
Your SSD may not like the RST driver. May I suggest in seeing if there is a firmware update for your drive, or switch to the MS AHCI driver manually. Or both.
[SIGPIC]Kicking Ass Since Today[/SIGPIC]

I've had the error that causes freezing, "The device, \Device\Ide\iaStor0, did not respond within the timeout period." The OCZ rep says its because hot plugging is not enabled in the bios for that drive(vertex 3 in my case). I haven't tried it yet but read somewhere there was no hot plugging setting in the bios(G73SW-A1). Gonna check it tomorrow.

Not applicable
Then what does it like xD? I only installed the IRST because I have problems. But it didnt get worse/better what I can tell so.

I have been in contact with corsair also, but they dont seem to know whats going on either so.
They wanted to replace my SSD but reading what others have said on the forums didnt really make me want to.
Some people got it replaced, but they even got more problems with their new ssd. Havnt read one single post where someone got it
fixed by replacement.

Anyways. I started to think it was the drivers because Neonfisk on this forum also had problems with Explorer not responding. However this were fixed when I uninstalled Asuswebstorage If I remember it right.
but the computer still freezes randomly 2-3 times a day. (which is a improvement, because it froze alot more before)

Level 7
Well I just bought the G74SX two weeks ago. It just died on me tonight. Running problem free since day one. GPU is dead. Between this and my R3E Black Edition, ASUS are on my crap list in a major way.

Not applicable
I sold a G74Sx-A1 to a customer which had the same issue. What I did:

  • Formatted
  • Installed VANILLA Windows 7 SP1
  • Installed nVIDIA Drivers(from nVIDIA's website)
  • Installed Realtek's drivers (from Realtek's website)
  • Installed Intel Chipset Drivers
  • Installed Intel MEI
  • Installed USB3 Drivers
  • Installed ATK Package .10
  • Installed KB Filter
  • Installed Card Reader Drivers
  • Installed BT Drivers

No problems so far and the laptop is fully functional. My guess is that the issue is either with some software installed along the OEM installation or one of the optional utilities I didn't install (they are not needed for proper operation) is causing the problem.