Showing results for 
Search instead for 
Did you mean: 

G74SX-A1Bricked after bios update

Level 7
I have an ASUS G74SX-A1 which I bought in the US while I was staying there. I have subsequently moved to Canada. Due to a series of unfortunate events my laptop seems bricked and the boot drive unreadable. Looking for assistance and suggestions. Excuse me for the wall of text.

I upgraded my boot drive to a Seagate SSHD 1TB by doing a byte for byte copy about 3 years ago. I don't have the original HDD. My laptop occasionally would freeze after restoring from Win 7 sleep mode. Though annoying, it was nothing that a hard reset did not overcome. So about 2 weeks ago, the same happened and I did a hard reset and was greeted to a 'BOOTMGR is missing' error. I thought maybe it was just a temporary error and tried restarting multiple times but that didn't work. I tried checking things in the BIOS and sometimes the boot drive showed up and sometimes it didn't. Believing that it couldn't have been a drive issue and that maybe the BIOS was not able to read an SSHD, I kept trying to toggle settings in the BIOS. I had previously updated the BIOS to 203 and upgraded to the new SSHD to try to resolve the sleep issue I mentioned before. Since resetting to factory defaults for BIOS did not work, I decided to flash 203 again suspecting that the BIOS was corrupted. I used EZ flash method, it said that it did not recognize the model number, but desperate and dismissive of that error I flashed it. It finished BIOS upload process, said it will shut down, shut down and did not power up as I was expecting it. It did have the green indicators on the front on but nothing else. But now on pressing power button nothing happens - no power button indicator, no processor/hdd/battery indicator. I suspect that the BIOS flash went wrong and it might be because I failed to see other people's note about using a FAT32 formatted USB. Mine was NTFS formatted.

Well with the laptop unresponsive, I at least wanted access to my data, So, I bought enclosures for my drives. Unfortunately, either during the BIOS flash or later during trying to access the data through the enclosure, the read head got stuck on the drive and started beeping(not clicking). I saw a few videos on how to unstuck it, opened the drive and did that. The drive now sometimes shows in Windows 10 (on another laptop) via the SATA to USB enclosure but immediately becomes unresponsive when read from. I have tried 2 different enclosures and both work with another drive (HDD though).

When the laptop BIOS was not flashed, I was able to boot through a USB into Hiren's Boot tool and even run mini Win XP. The SSHD at that time(before trying enclosures) did not show up in any of the tools on Hiren's image. I should have realized that it was disk failure and stopped then. Now the laptop doesn't power up, I dont have access to G74SX.bin since I cant read the boot disk. I tried Ctrl+Home BIOS recovery but I am unsure whether I am doing it the right way. I have a FAT32 usb with the 203 rom on it. So if someone can give me a detailed step by step process of trying to recover the BIOS that will be great.

What should the name of the bios file be?
I should remove both the battery and the adapter, then press power button? For how long?
Do I then connect the battery and the adapter?
Do I press Ctrl+Home or Ctrl+Alt+Home? For how long?
When and for how long do I press the power button?

All other suggestions are welcome as well. Thanks.