cancel
Showing results for 
Search instead for 
Did you mean: 

G74 green screen - need opinions

matador
Level 7
Comrades, I get green screen from my g74 during the boot up, when it goes into windows right after the sleep mode. It lasts only a sec, and doesn't create any problem.

Is this something I sshould be worried about, what do you think?

BTW, It's BBK8 model, and I still can return it.
4,621 Views
8 REPLIES 8

fuzon1337
Level 10
I had the same issue, but I reinstalled the notebook (for other reasons then exact green screen) and installed the latest nVidia drivers and then I haven't seen it after the reinstallation.

I think it's caused by the graphic driver so if you uninstall the driver you got know and then (after a reboot) install it again to see if it's gone away? (if you not already have tried this)
Asus G73SW-91058V 3D
- Intel Centrino Ultimate-N 6300
- BIOS 205

xeromist
Moderator
Sounds like the display adapter isn't initializing properly on startup. Run some heavy benchmarks like Furmark and see if you get any freezes or artifacts. If you to then return it immediately. If you don't then it's up to you. It might be a sign of deeper problems or you may never see anything worse. If you haven't already invested deeply and made your nest then I'd just take to to BB, show them the issue, and get an exchange. Better to be safe than sorry.

BTW, latest driver? You might want to make sure you have it and see if it happens to go away.
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

Thanks for the replies, folks. I just updated 285.62 to 290.36 Beta, and the issue went away. Also, the Skyrim seems to run smoother.

Do you think it's enough or should I run other tests also?

xeromist
Moderator
Tests are easy so I'd say it's worth it, but given Fuzon's experience I'd say you probably don't have to.
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

xeromist wrote:
Tests are easy so I'd say it's worth it, but given Fuzon's experience I'd say you probably don't have to.


Thanks a lot.

Animoski12
Level 7
I have this issue as well.. Interesting enough, I have the same model and from Best Buy as well..

Let me know if you ever get the green screen again during boot up on the beta drivers, or any other issues for that matter. I'm running the latest non-beta drivers.

Animoski12 wrote:
I have this issue as well.. Interesting enough, I have the same model and from Best Buy as well..

Let me know if you ever get the green screen again during boot up on the beta drivers, or any other issues for that matter. I'm running the latest non-beta drivers.


In a couple of days I'll provide an update on this situation.

matador
Level 7
First of all Happy Holidays.

Now the promised update - 290.36 driver works and no green screen. Today installed the 290.53 thing, which is working so far.