cancel
Showing results for 
Search instead for 
Did you mean: 

G74 Annoying Issues. USB 3.0, SD Card Reader, and Hardware noise.

pdorion
Level 7
I just bought a 1.0 TB Seagate portable hard drive that can run USB 3.0 and 2.0. I always plug it in through the USB 3.0 slot and it always tells me that its only running 2.0 and it can run faster with 3.0. I just ignored it and tested to transfer huge files. Sucks.. because its copying at USB 2.0 speed... Found some drivers here on the sticky and installed them and it still dint make any difference.. anyone have an answer to this?

Secondly, I wanted to copy pictures from my SD card but after i put the card in, it wont detect it. I tried several other cards and none of them get detected. Its like the slot is just for show....

Lastly, I noticed when I space out when im composing emails etc., some type of loud ticking noise is coming from the laptop. I think it might be the hard drive.

Help please..
271 Views
16 REPLIES 16

Hideaki
Level 7
I have also noticed a sporadic ticking noise - out of the blue, a single 'tick' about as loud as pressing a key - with my G74SX. I wonder where that's coming from.

Retired
Not applicable
It sounds to me like you received a damaged laptop, perhaps it was dropped or got wet from the elements?

I'd likely return.

Mine works fine with USB3 and no clicking noises here.

Actually I already have returned mine for other reasons (SSD somehow crashed and became unreadble after a few hours, no idea if there's any relation). So I guess I'll see how it is with the replacement.

So I just got my replacement G74sx and it also has that ticking noise. I think it's coming from the built-in speakers (even though right now they're disabled) and it seems to be in reaction to clicking something, usually.

xeromist
Moderator
Does it come through headphones if you have them plugged in?
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

Yes, it does. I played around a bit and setting my external speakers to maximum I found that the noise seems to always come up when something plays a sound after a period of silence.

It's like *click* sound is played, then higher than normal background white noise. Then after a few seconds the background noise goes down again with another click. And if I then play another sound it will click again.

xeromist
Moderator
Sounds like a problem with internal wiring. Could be a bad ground or a funky electronic switch. I don't think it would be an easy problem to trace and fix unfortunately.
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

Chastity
Level 10
Try muting your mics
[SIGPIC]Kicking Ass Since Today[/SIGPIC]

Tried muting the microphone, tried disabling it (and now I can't find it anymore, heh), tried plugging in an external microphone (+/- mute) but that noise still occurs.