Showing results for 
Search instead for 
Did you mean: 

G73jw touchpad driver bug workaround

Level 7
Hi all,

if you're reading this, most possibly you already know about at least some of G-series touchpad issues, here's 3 of them:

  • touchpad is not responsive ("hardware bug")
  • after working normally for a while, "tap" starts to result in pointer jumping to the upper-right corner of the screen ("driver bug"."symptom one")
  • momentum gets disabled simultaneously to previous effect ("driver bug"."symptom two")

The general discussion of touchpad issues is here: Troubleshooting ASUS G73 Touchpad Problems.
In this topic I'd like to start a discussion of a "SynReflash.exe /R" fix, which I hadn't heard before.

The story
  • Things were a lot worse before I've updated BIOS, as suggested in the topic mentioned, AND bought and replaced touchpad itself, removing underlying aluminum foil.
    This almost solved mentioned "hardware bug"
  • "driver bug"."symptom one" was almost "resolved" in Synaptics_v17_0_19_C_XP32_Vista32_Win7-32_XP64_Vista64_Win7-64_Acme_Inc driver. Now, when "driver bug" occurs again, cursor is not jumping to anywhere, instead, there's simply no "mouse click" when you "tap" - this is much less annoying.
  • Mentioned driver has a significant drawback - "driver bug" occurs significantly more often. Roughly once per 3 hours.

The workaround

For 3 years the only workaround I knew to recover from "driver bug" - to put notebook to "sleep" and to "wake up" it again. It worked in ~99% cases, if no - second iteration was always successful.

Today I've found a new workaround for "driver bug"!
After you install those Synaptics driver mentioned, you may use "c:\Program Files\Synaptics\SynTP\SynReflash.exe" tool to reset you touchpad driver when it gets crazy again. The only thing you need is to launch it and click "Refresh" button. Or, even simplier, you can launch it with "/R" parameter - just create a shortcut to this file on your desktop, and modify it's "target" to
c:\Program Files\Synaptics\SynTP\SynReflash.exe /R

The only my question is why there's no info about it over the internet?
Why those asus and synaptics officials wasn't suggesting it at least as a temporary fix? Were they not interested at all?