cancel
Showing results for 
Search instead for 
Did you mean: 

G73JW black-screen on waking from sleep/hibernation, also sometimes on boot

dains
Level 7
Hi, I just helped my sister buy a G73JW for my neph's graduation present. Unfortunately, it has the same issue as listed in all of the threads below. It black-screens on boot about 1 in 5 times and black-screens upon waking from sleep or hibernate about half the time. The black-screen symptoms are:

  • no video
  • just the power, left top and two left front lights on (never see the keyboard backlight come on), and
  • about 10 seconds later the fans come on loudly


Then the laptop stays like that and it takes a hard reset to try again.

This seems like either a video or BIOS problem, but I have updated the BIOS to 2.05, and I don't see a vbios update for the G73JW (460m card). So I'd like to ask for any information / suggestions people might have on this problem? It also has a bad GPU fan which I am replacing (got the part already and will repaste too), so I will be able to implement any suggestions while I'm in there.

Thanks for any help!

David

Same/very similar problems:
http://rog.asus.com/forum/showthread.php?27454-G53sx-not-posting
http://rog.asus.com/forum/showthread.php?23328-Asus-53S-Won-t-Turn-On
http://rog.asus.com/forum/showthread.php?16718-G74-would-not-start
http://rog.asus.com/forum/showthread.php?8882-G73JW-not-powering-on-%28ocationally%29
http://rog.asus.com/forum/showthread.php?2387-Asus-G53JW-Sleep-Mode-Help-Please
http://rog.asus.com/forum/showthread.php?1123-Not-waking-up-after-screen-turns-off
http://rog.asus.com/forum/showthread.php?2222-Asus-G73JW-Wont-wake-up-sometimes
http://rog.asus.com/forum/showthread.php?924-Asus-G73-JH-Display-Problems
8,189 Views
3 REPLIES 3

dains
Level 7
Update, I've discovered the laptop cannot make it past the "black screen" state if I remove the 3 additional memory chips, leaving only the internal 2 gig chip installed. If I put even one more chip back in, it returns to intermittent black-screening on boot.

Can someone confirm/deny whether the laptop should boot with only 1 2gig chip installed? If the answer is yes, then I suspect that chip or socket is bad.

Pitcher1
Level 9
if you have time, you can try every memory, if no, send back to reseller or ASUS service center to check.

Can you confirm for me if this laptop can run on 1 chip alone? If someone can say yes, that would confirm it's the chip/socket.

Alternatively, if it can run without a chip in that first socket, I'll just remove the chip and leave the socket empty to ensure the problem doesn't reoccur. Can you advise on whether it can run with an empty Slot 1?

Thanks for any help!