cancel
Showing results for 
Search instead for 
Did you mean: 

G73JW-A1 Screen Flicker / Nvidia display driver stopped responding & recovered

Retired
Not applicable
Hello,
I have had the laptop for a month. The screen flicker and black screen with the above error in the bottom right corner appears after surfing the net (mozilla/explorer/google chrome) watching video or gaming. I updated the drive via the ASUS website - did not solve it. I have read many threads regarding the G73JH having what I believe is the same issue? Can I use those remedies? Any help is greatly appreciated...thanks in advance!!
466 Views
21 REPLIES 21

Chastity
Level 10
Not the same issue. You just had a driver failure. I would update your Flash installation. Also, there is a new Notebook driver set (266.35) you can download from nvidia, in the beta section.
[SIGPIC]Kicking Ass Since Today[/SIGPIC]

Retired
Not applicable
Flash Installation...could you please point me in the right direction. I will try the nvidia download. Thank you!

Retired
Not applicable
jumbiegut wrote:
Flash Installation...could you please point me in the right direction.


Adobe Downloads! (see the "Readers and Players" section on the right...)

Retired
Not applicable
Thank you!

Retired
Not applicable
Well, looks like I need some help. After updating the bios, downloaded the latest flash, updated the nvidia driver to 266.35, I had the same flicker and screen would even lock up. Today I did a reinstall of the OS. After OS install, I had constant flicker and the screen would lock. I again updated the bios, latest flash and nvidia driver to 266.35. Still have the flicker issue. It happens during web surf, mozilla or chrome or IE, watching movies via vlc or wow gaming. Can anyone provide any help? Thanks in advance. While typing this "thread" the screen flickered, became unresponsive to mouse clicks or keyboard input...finally got the error message and recovery of the driver. Thanks in advance!!

Retired
Not applicable
The latest...I installed Win 7 64 bit from the G73 Series Driver and Application Reference Post...installed everything in order and after install of NVIDIA 265.96...Intel TurboBoost Technology Monitor (2.0) would not load...then...same issue as before "display driver stopped responding and recovered." I removed the Intel TurboBoost. Rebooted and now I have the repeated BSOD due to NVidia driver. I am in safe mode now. My second attempt...I installed everything from the G73 Series Driver and Application Reference Post, except the NVidia driver 265.66...once I installed the driver, BSOD, had to go to safe mode and try again. My third attempt...I again installed everything minus the NVidia driver 265.96 until the very end...STILL BSODs. I need some help. Up to the NVidia driver load, the laptop works great in Standard VGA mode. Thanks in advance!!

Retired
Not applicable
I am considering a G73JW, but all these graphic issues are starting to scare me off. Is there any validity to all this?

Chastity
Level 10
Did you install the Intel Monitor from the Driver CD? There are two parts to it, and will ONLY install from the Driver CD. There's the Intel TurboBoost Driver, and there's the Monitor. Do NOT use the download version, it will fail. Once working, you can update the Monitor portion from downloads.
[SIGPIC]Kicking Ass Since Today[/SIGPIC]

Retired
Not applicable
Ok, can you please confirm if this is the right strategy...I have now done a clean install of WIN 7 64 bit and the SP1; next should I just use the CD that came with the laptop and install all the drivers or use your post minus the Intel Monitor and TurboBoost; and leave all the ASUS software uninstalled? or?? Thanks for your help!! 🙂