cancel
Showing results for 
Search instead for 
Did you mean: 

G55 vw and razer onza TE

tan29
Level 7
hi, i just received my asus g55 last thursday and i was trying to plug in my razer onza turnament edition but my notebook does not recognise and need to instal the driver. while, as i checked razer website there is no driver provided and it is plug and play hardware. please help:)

tq
502 Views
16 REPLIES 16

kiba
Level 10
i had a similar problem with my razer naga epic, i never figured it out for sure (but then again i havent had time to mess around with it), i figured it must be a problem with usb 3.0 because it works on all my other notebooks/desktops, try testing it on another pc. Anyways here is the original thread:

http://rog.asus.com/forum/showthread.php?16619-Problem-with-USB-3.0-and-Razer-Naga-Epic&country=&sta...
ROG Notebooks: G75VW, G74SX, & G73JH And a gaming rig.

I faced the same issue as you, with my G55v model and the Razer Onza TE. I've been trying for the past few days to make it work and finally I managed to do so.

In case someone else is interested in the solution here it is:
I've had the latest USB 3.0 drivers from Intel site version: 1.0.5.235 and the XBOX 360 drivers from http://www.microsoft.com/hardware/en-us/p/xbox-360-controller-for-windows. Since neither of them solved the issue, I've removed both from my system and plugged the controller. I don't have any USB 3.0 support now since I don't have drivers for it, but the controller works just fine.
Please note I performed a windows update, just before installing all the drivers.

Hi AlexR3V,

I have the same problem, My windows update already installed. my current usb 3.0 ver is 1.0.3.214, do I need to install the latest driver? If so, where I can get the latest driver?

Thanks in advance 🙂

chopstix0331 wrote:
Hi AlexR3V,

I have the same problem, My windows update already installed. my current usb 3.0 ver is 1.0.3.214, do I need to install the latest driver? If so, where I can get the latest driver?

Thanks in advance 🙂


Well like I said all the latest driver did not help me, I had to go into Control Panel\All Control Panel Items\Programs and Features and remove USB_3.0_eXtensible_Host_Controller_Driver so basically I don't have any drivers for USB 3.0. I only had those default provided by windows.

In case you still want to try to update your drivers here is the link: http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=21129&keyword=%22usb+3.0%22〈=eng but I suggest to try my workaround to see if it works for you also.

AlexR3v wrote:
Well like I said all the latest driver did not help me, I had to go into Control Panel\All Control Panel Items\Programs and Features and remove USB_3.0_eXtensible_Host_Controller_Driver so basically I don't have any drivers for USB 3.0. I only had those default provided by windows.

In case you still want to try to update your drivers here is the link: http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=21129&keyword=%22usb+3.0%22〈=eng but I suggest to try my workaround to see if it works for you also.


Hello again,

I just try to remove the usb 3.0 extensible host controller, but all my usb port didn't work after I restart my laptop, where did you find the default provided by windows, sorry bro I'm just it's my first time to have this machine 🙂

Thanks once again

chopstix0331 wrote:
Hello again,

I just try to remove the usb 3.0 extensible host controller, but all my usb port didn't work after I restart my laptop, where did you find the default provided by windows, sorry bro I'm just it's my first time to have this machine 🙂

Thanks once again


Don't worry I'll try to help, I'm going to tell you all the things I have installed and are relevant.
First I have Windows 7 SP1, with all updates, I have Chipset drivers from Asus site. If i check my device manager under Universal Serial Bus controller I have exactly 8 items (none of them USB 3.0), how many do you have ?
My USB worked right after fresh install of windows, I've copied all the drivers from a USB drive so you too must be able to use your ports but not with USB 3.0 devices, try with a 2.0 flash memory .
If you don't have any items under USB controller in device manager try to install Chipset drivers again, btw do you have SP1 ?

AlexR3v wrote:
Don't worry I'll try to help, I'm going to tell you all the things I have installed and are relevant.
First I have Windows 7 SP1, with all updates, I have Chipset drivers from Asus site. If i check my device manager under Universal Serial Bus controller I have exactly 8 items (none of them USB 3.0), how many do you have ?
My USB worked right after fresh install of windows, I've copied all the drivers from a USB drive so you too must be able to use your ports but not with USB 3.0 devices, try with a 2.0 flash memory .
If you don't have any items under USB controller in device manager try to install Chipset drivers again, btw do you have SP1 ?


I have 9 items under Universal Serial Bus of my laptop. I'm using Windows Home Premium SP1. I don't installer for windows 7 SP1

Thanks

chopstix0331 wrote:
I have 9 items under Universal Serial Bus of my laptop. I'm using Windows Home Premium SP1. I don't installer for windows 7 SP1

Thanks


But have you tried a simple flash drive to see if it works ? If it works, then Onza should work too. I have Window 7 Ultimate, maybe that's why it's different.

AlexR3v wrote:
But have you tried a simple flash drive to see if it works ? If it works, then Onza should work too. I have Window 7 Ultimate, maybe that's why it's different.



Well I guess I'll buy new controller that is compatible with this machine or maybe I'll use my old controller which is logitech rumblepad f510. I'll give my razer onza to my brother.

Thanks for the help 🙂