Showing results for 
Search instead for 
Did you mean: 

[G55] [ElanTech Touchpad] Use both buttons at the same time

Level 7
As the title states, I can't use both touchpad buttons at the same time. Thus making FPS unplayable (can't aim & shoot)
I've tried with older and newer drivers, and the issue remains.
If I uninstall Elantech drivers and use the generic Windows driver, I can use both buttons, but tap-to-click is always enabled, and I hate that feature (I accidentally tap all the time).
Any suggestions to use both buttons at the same time and have tap-to-click disabled?
Thanks in advance.

PS. Please don't suggest to use an external mouse. I like gaming with the touchpad.

Level 9
install ATK driver try again, do you mean when you install touchpad new driver from asus website still not fix?

The issue is that if I'm holding the right mouse button (to aim), I press the left button (to shoot) and doesn't work.
It's not a hardware issue, because with the generic Windows driver (no Elantech) it works OK.
I have Elantech driver v11.5.6.6.

I've got the same problem on my G46 and haven't seen anybody with a solution, or even acknowledge it as a problem... I'm glad I'm not alone ha! I do like to do some mobile gaming and it's exactly as you say, when I aim down the sights, I can't fire! External mouse obviously solves it but that isn't the solution I want all the time. I also have a Elantech touchpad. I am using the Elantech drivers from Asus.

I didn't realize it worked with the generic drivers, I'll have to try that. I was afraid it was a hardware limitation for some weird reason. I do hate the thought of losing the extra touch gestures.
Asus G46VW - i7-3630QM, Crucial m4 256GB mSATA SDD, 750GB HDD, 16GB Vengeance 1866, Nvidia 660mGTX
Asus G73JH-RBBX05 - Samsung 256GB 840 PRO SSD, WD 750GB Black 7.2K, 6GB, Bluray

Level 7
Has anyone found a solution for this? I'm seriously thinking of returning mine and getting something else with an alps or synaptics due to this.
The genetic drivers don't offer scroll either, besides a tap to click disable. wtf were they thinking.

I have the same problem on g750jh cant shoot and fire at the same time if anyone has a workaround please tell

Level 8
Has anyone came up with a way to get this working yet?

Level 7
i think no one came up with a solution
still this is pissing me off

Level 7
I have the same issue on my G750 and I do agree with you all that it really is poor in a gaming laptop and will put me off making any future purchases
of Asus laptops. How on earth do they ever manage to make it so you cannot press both buttons simultaneously. I also get erratic movements where
the cursor will jump 5-10 mm which is annoying when healing in MMOs since I position my cursor to make the heal and then look at the player's portrait
and then when I press the button, the cursor jumps so I am not hitting the icon. I am really disappointed with the trackpad which ruins the machine
for me. I edit documents and if I right-click to correct, sometimes the jumping of the cursor causes me to select the wrong correction. I won't buy
an asus laptop in the future which is a pity because otherwise this is a great machine. Can someone link me a generic windows 8.1 touchpad driver please?