Showing results for 
Search instead for 
Did you mean: 

[G53JW] Laptop bricked after BIOS update (second time!)

Level 8
TL;DR - I updated my BIOS and now my laptop is completely non-responsive.

Backstory: I bought my G53JW from Newegg in March of 2011. The first day I got the laptop, I updated my BIOS using the EasyFlash utility. I even used a USB drive like it recommended, despite never using one for any other BIOS flash. While the BIOS was flashing, I went to the bathroom. When I came back, my laptop was bricked. Completely non-responsive. I never knew what happened. I called ASUS and they told me that I had broken the laptop and they could not fix it for free. They implied I flashed the BIOS incorrectly (While possible, unlikely) and that I did not have a legitimate reason to be flashing the BIOS. Surprised by the lack of support I was receiving from ASUS, I contacted NewEgg and was able to convince them to ship me a replacement since I was within my 30-day replacement window. The laptop worked fine for about a year, but then I ran into a problem with my DC Jack breaking. This was fixed under warranty (after a big hassle with ASUS) and my battery was replaced. That worked perfectly for about a year and a half.

A couple months ago, my laptop started doing this weird thing where it would constantly switch between AC mode and Battery mode. I have seen laptops do this before, but not exactly the way my laptop was. It would switch modes even when I took the battery out of the computer. I lived with this for a while before asking a friend at work to help me out (I work in a "Tech Support for Students" department of a University) He has more experience with hardware than I do, so I had him take apart the computer. He noticed a strange residue around the charge port (on the motherboard) and also noticed that one of the pins was bent in the wrong direction. The residue was cleaned using alcohol swabs and the pin was bent into the proper location with a soldering iron. After that, the laptop worked perfectly for 2 days. Then the power settings started switching back and forth again. I decided to look into another solution: Updating the BIOS.

I was scared to do this because of my initial experience with the BIOS, but I was confident that things would work better this time. Like I mentioned, I work in a tech support department for a University. I've performed plenty of BIOS updates and never have problems with any machine except my own laptop. I was careful to read the instructions on how to properly flash the BIOS, but encountered the exact same problem that I had experienced 3 years ago. My laptop is now completely bricked, again. I haven't called ASUS about it yet because of how poorly I was treated when I went to them with this problem 3 years ago. I have tried to do some research on fixing this issue myself, but I figured posting here would be the most accurate source of information.

Thank you for your time and responses,

Level 7
Did you format the USB drive first? Eazyflash doesn't work properly if there are folders and such on the drive.

if you are out of warranty the only cheap fix is reprogramming the bios with a spi compatible programmer you will need to check your motherboard uses an spi flash chip I assume it does, i reccommend the buspirate, this is very easy to do as well esp if you have a soic8 chip clip. You should only need to spend $40-50.

You will need to research the chip pinouts and match with the buspirate pinouts, best way is to get a soic8 clip and an adaptor board, and attach the clip, a small indent on the chip usually denotes pin 1.

And you will also need to get the latest flashrom which has buspirate support, install drivers for buspirate and note what com port it uses and replace 'COM3' in the console commands below with your own.

1) assemble the clip and buspirate according to pinouts etc and attach to the bios chip.

-in Command Prompt do 'flashrom -p buspirate_spi:dev=COM3,spispeed=1M' it should detect your bios chip and display the name of the chip. If it does you are in business.

2) You wiill need to read your bios flash chip contents with the latest flashrom and save as 'g53-bricked.bin' the filename isnt important but just so you know what is what.

-Do 'flashrom -r g53-bricked.bin -p buspirate_spi:dev=COM3,spispeed=1M'
and verify 'flashrom -v g53-bricked.bin -p buspirate_spi:dev=COM3,spispeed=1M'

3) Download the latest bios update from the asus website. Extract and save as 'g53-update.bin'

In a hex editor you will need to overwrite the contents at the end of 'g53-bricked.bin' with the contents of 'g53-update.bin' so the file will resemble what it should have been had the update been successful in the first place. Save as 'g53-unbricked.bin'.

4) using flashrom write flash chip with 'g53-unbricked.bin'

-Do 'flashrom -w g53-unbricked.bin -p buspirate_spi:dev=COM3,spispeed=1M'

5) Laptop will work again.

This is the buspirate setup when I unbricked my own G74SX.
[G74SX-BBK11] 1080p i7-2670QM GTX 560M 2GB 8GB RAM 128GB SanDisk SSD BIOS 203 /w BD-PROCHOT disabled


After looking around in the Bios and a reboot, I think that my bios are broken too.

I have tried: Taking out Battery, With bios battery pressing continuously ESC, F1, F2, F4, F8, F9, F10 and DEL, Without Bios Battery whlie pressing continuously ESC, F1, F2, F4, F8, F9, F10 and DEL.

But nothing works, it is still stuck at the ASUS logo.

The only life I get is some blinks while pressing Num lock and Caps lock.

Any Ideas?

Where on the motherboard can I find the bios chip? I am not use to laptop bios chips.

Why do I need to use hexedit and pase new bios into the bricked bios file instead just flash straight on with the one from asus homepage?

Thanks in advanced


Level 9
There was some talk here about a crisis bios flash involving holding down the ctrl and home keys and pushing and holding the power button then machine goes into crisis bios repair mode, if it is the correct unit. However, the bios to be flashed has to be in the root directory with the extension listed as .BIN . Search this around and see if it helps.