Showing results for 
Search instead for 
Did you mean: 

G46VW and Elite Dangerous

Level 7
Hi, I have the following issue with Elite Dangerous, nobody has a clue on this one, and I've talked to a LOT of people and tried a LOT of things to resolve it. It has persisted throughout the beta and gamma stages of the game and is still affecting the retail version.

First you should know that the game has a launcher and a client. It's designed so that the client will not work unless the launcher, which is called from the desktop game icon, is run first.

If I start the game from the desktop icon, the launcher runs and loads the game client. It's possible to go through the initial game menus and options without issues.

As soon as a Play option is chosen from a menu, at which point I am assuming the 3D engine should kick in, the game immediately freezes and crashes to the desktop with a message from Windows that the Nvidia driver has stopped and recovered.

There are two viewing options in the game config menu, either "fullscreen" or "borderless window".

If I have selected "borderless", the above happens PLUS there's an obscure error message stating that a file has failed to load. No indication WHAT file, just A file. The recommendation is to reinstall the game, or turn off antivirus, or both. If "fullscreen" has been selected, I only get the Nvidia driver crash message. In either case the game crashes every time.

However ...

If I right-click the desktop icon and select Intel Integrated Graphics, both the launcher and the game then work. The only thing that doesn't work, is that the game does not exit correctly to the desktop at the end but freezes on a black screen; this may also be video driver related, but there's no error message. I just have to log out of Windows and then back, because for some reason Explorer has frozen up too.

The system is configured to have the Nvidia card as the default, but this also happens if I configure it to let the system choose. The Intel card is configured for best performance.

In the Nivida control panel I have tried various options but regardless of what I choose as default, or set manually or attempt to force, exactly the same game crash at start and exactly the same error message is displayed.

The Windows logs show in all cases that the Nvidia driver has crashed, nothing else.

I have tried using drivers from months back, all the way through to the most current ones. I have done clean driver uninstalls using a third party app. I have in short tried to think of everything I can to try, and I still can't start this game unless I manually select Intel Integrated graphics from the mouse menu.

I have downloaded and reinstalled the entire game, twice. I have turned AV off. I have been through the process list and turned off every unimportant process I can find.

I have written many posts and sent endless crash reports to the game devs, with no response over many weeks. I have yet to find anyone with the identical stock Asus G46vw laptop who is trying to play, or has succeeded in playing, this game without having to select the Intel graphics. I do know that the game runs on the regular GTX660, and way back I did see a posting somewhere from someone who has a different laptop running the GTX660M without any issues. So I think it must be an issue with this laptop, because I've run out of other ideas.

Please excuse the long posting, I've tried to get as much diagnostic information in here as I can.

Thanks in advance for any help.

By the way I should also say that every other 3D game I have - including things like Alien Isolation, and Styx, and Shadows Of Mordor, all run perfectly fine and glitch-free. Most games will run at high or ultra settings or some combination of those, and Elite Dangerous is not an intensely demanding game. The onboard GTX 660M is well within the game requirements.

Again thanks, I'm bald from tearing my hair here ... 😞