cancel
Showing results for 
Search instead for 
Did you mean: 

Forcing a program to use the Nvidia card in the CP doesn't do anything - G751JM

falkenjeff
Level 7
Click to enlarge.



Note in the image:


  • I have selected the entire game folder and told it to use the NVidia card in the NVidia control panel (I have also tried individually adding the files - that doesn't work either)
  • The game, Phantasy Star Online Blue Burst is running (the game folder I am referring to).
  • GPU tweak, in the background, says the intel GPU is being used
  • The "NVidia GPU activity" icon in the system tray also says the NVidia GPU is not being used


I have tried (months ago) to run other programs with the NVidia GPU. For example, webpages running flash video (by trying to force Google Chrome to use the NVidia GPU), VLC Media Player, Media Player Classic, etc... And it has NEVER worked, not even once. The only programs that will use the GPU are actual games that are recognized by "NVidia Geforce Experience" and are able to download profiles and stuff (which I don't even use), and the control panel itself. Up until now it has been fine - videos and stuff, for the MOST part, run fine on the intel card; any choppiness or FPS drops in the videos might not even be the video card's fault, it could be internet lag or streaming issues. League of Legends and Starcraft 2 run fine and use the NVidia GPU, and those were the only games I played.

Well, until now. I downloaded a PSO Blue Burst private server, and it is not using my NVidia card. No game profile exists in Geforce experience, because the game is no longer supported by its developer, SEGA (and all official servers have been shut down). The game DOES run fine, it's not a huge issue - IF I RUN IT AT 1280x720. If I run it at 1280x720 full screen, I will get 30 FPS and it will never drop (the game is one of those old games that is locked at 30 FPS). But if I try to run it windowed, or if I try to run it at 1920x1080 full screen, the FPS occasionally drops and the game becomes unplayable.

So I would now like to know why the heck my G751JM ABSOLUTELY REFUSES to use my NVidia card for ANYTHING that isn't a game officially recognized by NVidia and its game profiles/experience tool. Other people are able to run this game in 1080p just fine, but I can't because I'm on a garbage intel card and forcing it to switch absolutely does not work, and never has.

Note: In the past (with VLC and stuff) I have tried right clicking and using the context menu to select the NVidia card - that has also never worked, and with the current NVidia drivers that isn't even an option anymore, it just tells you to use the NVidia control panel.
13,033 Views
21 REPLIES 21

falkenjeff wrote:
Talked to Nvidia support. They told me it's up to the GAME DEVELOPER to make sure Optimus selects the right card, and that it's not a driver issue at all.

What a ****ing load of crap.


Did you make sure your nVidia driver was matched to your build of nVidia inspector? Have you engaged your game's support?

Have you tried abandoning Optimus? http://superuser.com/questions/484962/how-to-force-my-laptop-to-use-the-discrete-gpu

joshindaphils wrote:
Did you make sure your nVidia driver was matched to your build of nVidia inspector? Have you engaged your game's support?

Have you tried abandoning Optimus? http://superuser.com/questions/484962/how-to-force-my-laptop-to-use-the-discrete-gpu


1) Yes

2) Game is no longer supported by the developer

3) I cannot force any program to use the Nvidia card if it does not auto-select it by default, even using global settings. The strange thing is, I CAN force a program to use the integrated card if it uses the Nvidia card by default (tested with League of Legends).

I've basically tried everything short of resetting my system to factory defaults (which I really don't want to do due to massive windows updates and monthly bandwidth limitations).

aeolisio
Level 10
Google search took me less than a minute to see this is clearly a problem with the game not Asus or your g751. Maybe if you spent half the time looking for a solution on google as you did bashing asus on these forums you could have saved us from reading your negative comments. But im sure youll go back and edit your posts when you do finally figure out that this has nothing to do with asus and apoligize right.....
https://forums.geforce.com/default/topic/528621/can-39-t-disable-integrated-intel-hd-graphics/
Sometimes you will need to add more EXE in the profile to runs the game on geforce (the built-in profile aren't perfect)

Try running the game and then go to Task Manager to see which EXE is actually being used by the game, and then add this EXE in profiles to runs with geforce.
Or you can just add all the EXE you found in the game folder including the game launcher 🙂

Uses same client as POE
http://steamcommunity.com/app/238960/discussions/0/540733524367284085/
In PoE my entries in the adapter field are: 1.) "Intel HD Graphics #0", 2.) "Intel HD Graphics #1", which does not really help.
Actually just setting the "pathofexilesteam.exe" (which can be found under "\steam\steamapps\common\path of exile\") in your nvidia system control panel, to use your nvidia GPU, should be sufficient. It is for me.

http://churchofkeysus.com/pathofexile.com/forum/view-thread/105676/page/2
https://www.pathofexile.com/forum/view-thread/13625/page/3
3d printed parts and accessories for the G751. You know you want something better than OEM ->https://www.shapeways.com/shops/aeolisio[SIGPIC][/SIGPIC]

aeolisio wrote:
Google search took me less than a minute to see this is clearly a problem with the game not Asus or your g751. Maybe if you spent half the time looking for a solution on google as you did bashing asus on these forums you could have saved us from reading your negative comments. But im sure youll go back and edit your posts when you do finally figure out that this has nothing to do with asus and apoligize right.


I already tried all that. The game is not the ****ing problem.

The game I am playing doesn't have a built in profile. I had to make the custom profile myself. I, therefore, attempted many solutions (adding the entire game folder to the profile using a wildcard, adding every single exe in the game folder to the profile using Nvidia Inspector instead, adding my game's exes to my League of Legends profile using Nvidia Inspector since I already know League of Legends works, etc etc). None of it worked. I also tried every single option I could think of using Nvidia Inspector, including ALL the "optimus flags for enabled applications" options, and not just the recommended ones. No matter what I do, my "Nvidia GPU activity" in the taskbar shows that the card is not being used.

Are you going to apologize? Because you were kind of a dick, making assumptions and assuming I hadn't Google'd and tried every ****ing solution I can find (aside from a complete reset to factory defaults of my entire machine).

falkenjeff wrote:
I already tried all that. The game is not the ****ing problem.

The game I am playing doesn't have a built in profile. I had to make the custom profile myself. I, therefore, attempted many solutions (adding the entire game folder to the profile using a wildcard, adding every single exe in the game folder to the profile using Nvidia Inspector instead, adding my game's exes to my League of Legends profile using Nvidia Inspector since I already know League of Legends works, etc etc). None of it worked. I also tried every single option I could think of using Nvidia Inspector, including ALL the "optimus flags for enabled applications" options, and not just the recommended ones. No matter what I do, my "Nvidia GPU activity" in the taskbar shows that the card is not being used.

Are you going to apologize? Because you were kind of a dick, making assumptions and assuming I hadn't Google'd and tried every ****ing solution I can find (aside from a complete reset to factory defaults of my entire machine).


Try the latest Intel Graphics driver and NVIDIA Driver.

also NVIDIA Optimus and hybrid graphics in general sometimes have problem running on dGPU in window mode so try running the game in full screen mode.

Sanctrum
Level 9
@falkenjeff - please try this workaround:
1. Install Oracle VirtualBox (as it is the best solution when you want to use 3D acceleration), you find it here: https://www.virtualbox.org/ + install Oracle VM VirtualBox Extension Pack
2. Create virtual machine and install there Windows XP.
3. Install at virtual WinXp in the safe mode VBoxGuestAdditions + checking 3D acceleration = the drivers to properly use your hardware by virtual machine. Do not install any NVidia drivers at virtual machine!
4. Reconfigure virtual WinXP to work in the full screen mode.
5. Install your legacy game at virtual WinXP... and enjoy.

Please report back it is working for you...

P.S. Do not expect any vendor to do anything official regarding the game that is LEGACY/EXPIRED/NOT SUPPORTED.

Sanctrum wrote:
@falkenjeff - please try this workaround:
1. Install Oracle VirtualBox (as it is the best solution when you want to use 3D acceleration), you find it here: https://www.virtualbox.org/ + install Oracle VM VirtualBox Extension Pack
2. Create virtual machine and install there Windows XP.
3. Install at virtual WinXp in the safe mode VBoxGuestAdditions + checking 3D acceleration = the drivers to properly use your hardware by virtual machine. Do not install any NVidia drivers at virtual machine!
4. Reconfigure virtual WinXP to work in the full screen mode.
5. Install your legacy game at virtual WinXP... and enjoy.

Please report back it is working for you...

P.S. Do not expect any vendor to do anything official regarding the game that is LEGACY/EXPIRED/NOT SUPPORTED.


2 questions:

1) Will the entire virtual machine be running on my Nvidia GPU?

2) Do I need to purchase a license for Windows XP? (I don't actually have any old keys)

I won't be able to test it until a later date, due to limited bandwidth (that's part of the reason I got the gaming laptop - I have to physically move it to a hotspot for large downloads).

Sanctrum wrote:
@falkenjeff - please try this workaround:
1. Install Oracle VirtualBox (as it is the best solution when you want to use 3D acceleration), you find it here: https://www.virtualbox.org/ + install Oracle VM VirtualBox Extension Pack
2. Create virtual machine and install there Windows XP.
3. Install at virtual WinXp in the safe mode VBoxGuestAdditions + checking 3D acceleration = the drivers to properly use your hardware by virtual machine. Do not install any NVidia drivers at virtual machine!
4. Reconfigure virtual WinXP to work in the full screen mode.
5. Install your legacy game at virtual WinXP... and enjoy.

Please report back it is working for you...

P.S. Do not expect any vendor to do anything official regarding the game that is LEGACY/EXPIRED/NOT SUPPORTED.


HyperVisor will not work with GPU acceleration unless you have a certified GPU like NVIDIA Grid or AMD SKY through remotefx.

Also I just realized the game is from 2003 with not so demanding graphics. HD 4600 should be able to handle the game at decent FPS since the game is so old.

rcarlos243 wrote:
HyperVisor will not work with GPU acceleration unless you have a certified GPU like NVIDIA Grid or AMD SKY through remotefx.

Also I just realized the game is from 2003 with not so demanding graphics. HD 4600 should be able to handle the game at decent FPS since the game is so old.


1) Can't handle it windowed at all. And the game is trash and crashes if you alt tab while in full screen mode, so not being able to play borderless window kinda sucks.

2) Can't go above 1280x720 even in full screen mode without dropping FPS.

If I play 1280x720 fullscreen is runs fine. But yeah.

Sanctrum
Level 9
@falkenjeff
1) Probably, but not 100% percent sure (I do not have your setup) but: Example: MacBook users reports/complaints that in their case VBox is always using discrete Nvidia card (causing the faster battery drain) instead of the Intel one... even if the virtual machine is not using any 3d acceleration at all - just desktop. Other laptops I have contain ATI mobility card... there you can set at BIOS to use only ATI, so I can not test it for you.
2) Yes you need the license. It is not the crappy Windows XP Mode at Win7... but Vbox is much more powerfull at 3D and in general outclasses MS Virtual PC. So in this case you must have the license/key and you must activate the system like at normal installation... or just wait with the activation/system deletion after the testing.

Also remember that Vbox 3d acceleration is not 1:1 your hardware provides... but for the legacy games it should be more then enough... I am playing 3D games at my Ubuntu virtual machine at Vbox... Eg Quake III Arena...