cancel
Showing results for 
Search instead for 
Did you mean: 

CPU FAN not working :( G750JX

cristian_g
Level 7
Hello ROGers!

I have a major issue with my G750JX. I tried installing Mavericks couple of times yesterday and it was getting stuck at some kind of "bootcache" error, whatever I gave up. The only way I was able to shut it down was via power button.

Now, the thing is that until yesterday everything was working fine. After 3rd or 4th forced restart my laptop started shutting down after couple of seconds even in BIOS! managed to do the F9 F10 combo really fast ( restore optimized defaults and save&restart) and somehow solved the reboot problem.

Today I was playing some DOTA and suddely the laptop just switched of (and probably pissed of some playes for sure 😄 ). I rebooted, reconnected quick but after 3 minutes again BAM! Then I noticed that the left fan is not working, I believe it's the CPU.

What could be the problem here? maybe that mavericks attempt messed up my settings? Earlier got the idea of reflashing the 209 BIOS when I will get back home, otherwise I am out of ideas.

Any suggestions?
6,652 Views
8 REPLIES 8

cristian_g
Level 7
cristian.g wrote:
Hello ROGers!

I have a major issue with my G750JX. I tried installing Mavericks couple of times yesterday and it was getting stuck at some kind of "bootcache" error, whatever I gave up. The only way I was able to shut it down was via power button.

Now, the thing is that until yesterday everything was working fine. After 3rd or 4th forced restart my laptop started shutting down after couple of seconds even in BIOS! managed to do the F9 F10 combo really fast ( restore optimized defaults and save&restart) and somehow solved the reboot problem.

Today I was playing some DOTA and suddely the laptop just switched of (and probably pissed of some playes for sure 😄 ). I rebooted, reconnected quick but after 3 minutes again BAM! Then I noticed that the left fan is not working, I believe it's the CPU.

What could be the problem here? maybe that mavericks attempt messed up my settings? Earlier got the idea of reflashing the 209 BIOS when I will get back home, otherwise I am out of ideas.

Any suggestions?


Cmon guys anybody there? This was supposed to be RoG community

Darnassus
Status Under Review
Sorry about that.

I believe reflashing your BIOS would be the best bet.. if you're confident however.. I believe you can dismantle your unit down to the motherboard (but not take off the CPU / GPU's) without voiding your warranty to see if.. by some retarded reason your CPU Fan wire has unplugged or somehow been damaged.

But yes, if you reflash the BIOS, make sure it's on a good, reliable USB and done in the BIOS utility itself, not off the hard drive.. apparently doing it through a program on the hard drive causes problems.. though I can't be certain from hearing it from a couple people. You might need to do a little research or another user may be able to share their findings.

When I updated the bios I did it the old fashioned way - straight from bios, not the software way. I am a bit worried about tearing it apart , it's kind of a headache from what I've seen on YouTube 😄 . I will report back later after I flash it. If not Asus service here I come 😞

gazzacbr
Level 10
Hi,
if you are reflashing your bios try with 208. there have been 'some problems' with 209.
when did you update to 209?
Asus G750JX-CV050H||GTX770M||24GB ram||120hz 3D screen||
1TB Samsung 840 EVO SSD||500GB Crucial M4 SSD||500GB Crucial M4 SSD in DVD Bay
free bag and mouse :cool:
win 8.1||win 7||win xp||server 2008||os x mavericks||linux mint 16

i updated right after it came out, jumped straight from 207 (i had that problem with cpu staying at 0.77 when on battery). so far i had no issues. will give it a try with 208 first and reply tonight around 22:00 CEST. cant do it now because i am at work and cant afford losing my progress 😄

cristian_g
Level 7
i tried to reflash 209 and it says build date of the bios is too old!!! i guess i cant flash 208 either 😞

Wulff
Level 9
http://rog.asus.com/forum/showthread.php?11438-How-to-downgrade-your-Bios-using-Winflash

there its explained how to remove the date check in winflash

Darnassus
Status Under Review
I'm on 208 and won't even DARE go to 209. I've heard too much crap go on with 209. And all it fixes is WQHL checks and so on. Unnecessary stuff in my opinion.

208 is the stable standpoint in my opinion.