Showing results for 
Search instead for 
Did you mean: 

Collection of Some G750 Touchpad and Touchpad Button-related Threads

US Customer Loyalty Agent
Rather than include a lot of sticky threads to clutter up this sub-forum, some are arranged by topic below with links.
Planning to edit and update this post later, and thanks to all who contributed.
If anybody would like to post in those threads, feel free to pull them up to reply rather than posting in this thread.

1. Subject: Win8 Games Randomly Minimizing while using Touchpad

Thread (clickable): Win8 Games Minimizing because of touchpad [solved]

First post from the thread:

Aletreus wrote:
I recently purchased a ASUS G750JW-DB71 and while it runs smoothly, I am running into issues while playing games. My games keep on minimizing randomly. I'm not sure why, but it's just becoming an annoying issue. How do I get rid of this issue? Any help will be appreciated. Thank you in advance.

2. Subject: Left-click Touchpad Button Intermittently Responsive when used in Combination with the Keyboard in Win8.1 (and Minecraft?)

Thread (clickable): G570 Left Click issues when typing [solved]

First post from the thread:

veteranmina wrote:
Okay, so I am a very big Minecrafter and this machine is a beast at running it.

My only issue is that I cannot get the left click to fully register my clicks all the time, meaning it is intermittent on responding.

Weird thing is that the left click registers clicks at anywhere else BUT minecraft. I have looked all over in minecraft for a answer,
but I have not so I have decided to come here and see if anyone else has come across this.

What I have done:

External mouse works fully
Fully updated drivers/firmware
Fully updated windows updates
Changed multiple settings for mouse/touchpad

3. Subject: Cannot Left-click while holding Right Touchpad Button

Thread (clickable): ELAN Touchpad: Enable simultaneous click button pressing

First post (partial) from the thread:

Act32.97 wrote:
As some G750 owners may already know, ELAN Touchpad drivers don't register a press of one of the click buttons when the other button is being held down. This is not a problem in most cases, but is a big problem in some games which require the right button to be held down in order to aim and the left in order to fire.

Fortunately there is a way to get one button to register while the other is being held down. Unfortunately it requires installing a different touchpad driver which will result in all of the smart features being removed, including the scroll feature (aka virtual mouse wheel). Basically, the only features that will still work is the tap to click feature and the physical click buttons. It is up to you to decide which feature is more important to you (smart features vs use both buttons at once).

Here's how to switch drivers and enable simultaneous button pressing if you choose to do so...

4. Threads Related to Disabling the Touchpad

4a. Subject: Fn+F9 to Disable Touchpad Stopped Working After Windows Automatic Update

Thread (clickable): My FN+F9 just stopped working [solved]

First post from the thread:

Zacharyp1 wrote:
After a Windows automatic update this morning, I noticed my touchpad was activated again (as I have always had it turned off.) Once it rebooted and I went to desktop, I tried to turn the touchpad off and the FN+F9 was of no use. It is important for the pad to be off since my hand rests partly on it while playing games. Should I try and find the pad software and delete it?

4b. Subject: Unable to Disable G750JM Touchpad

Thread (clickable): Disabling g750jm touch pad

First post from the thread:

TheRiddl3r76 wrote:
I have tried to disable the touchpad on my laptop. i have the g750jm i have downloaded drivers and followed other steps i cant disable it. Not even using the function keys allows it to work. Please help me!

4c. Subject: Fn+F9 to Disable Touchpad not Working

Thread (clickable): The Infamous FN+F9 Refuses to Function Properly

First post from the thread:

knight1fox3 wrote:
well the title pretty much says it all. Decided to post here because I've tried numerous remedies reading various threads. So far I can't get FN+F9 to work properly. All other FN+ keys seem to work fine except the touchpad toggle. I read through this entire thread:

I tried the suggestions there but to no avail. I also downloaded/installed the latest ATK package along with the Elan driver. A bit of history, I have the G750JX model that came pre-installed with Win8.0. I had issues trying to upgrade to 8.1 so I started with a fresh install and updated to 8.1 that way. I really don't have much else installed at this point aside from all the required device drivers. I'm looking for any tips/suggestions that might help solve the issue. This was another interesting article with a few suggestions but again, did not work for my setup.

Thanks in advance!