Showing results for 
Search instead for 
Did you mean: 

Can't access BIOS on Asus G751JY

Level 7
I have an Asus G751JY from 2015. In 2019 I upgraded the BIOS to support NVMe M.2 SSDs according to this tutorial:

It has worked great since then and I was able to upgrade my stock SSD to a Samsung 970 Evo Plus.
I have 3 partitions on this SSD and a couple of days ago I was uninstalling some software from one of the partitions when the uninstall process froze. I forced the shutdown and when I tried to boot to this partition the screen remained black.

So I booted to another partition and forced Windows 10 to boot in safe mode on the partition I was uninstalling the software. I still couldn't boot on that partition. So I once again booted to the primary and good partition and forced Windows to start in safe mode on that primary partition. This was the end of everything.
Now I can't see anything but a black screen. I can't access BIOS, I don't see the ROG logo and I can't see the multiboot menu to select the partition I want to boot from.

The backlight is on. I have already took my pc to a professional pc repair shop and they disassembled the chassis to disconnect the battery and the CMOS battery and it still isn't working.

If I remove my Samsung 970 Evo Plus SSD and install the factory one with Windows 8.1 on it, the computer boots and runs Windows without a glitch. I still can't access BIOS and I still can't see the ROG logo.

I believe I am being able to actually enter BIOS when I press F2 when turning on, but I have no image on the computer screen or any external monitor (I tried to connect through VGA and through HDMI). I believe I enter BIOS because if I do press F2 when powering on, then the computer doesn't boot to Windows (on the factory SSD) and if I press F10 and Enter I hear the typical sound of the computer restarting.

I have already downgraded to the factory BIOS that came with the computer (I saved that BIOS file on the factory SSD while following the tutorial to upgrade the BIOS, and with the afuwin64 software I was able to downgrade my custom BIOS to the factory one), but still I can't access BIOS or see any logo while booting. I have also already flashed BIOS 213 from Asus, and I have also tried to upgrade that BIOS to support the NVMe M.2 SSD. Without any luck whatsoever.

Is there anything I can do to this pc to get my NVMe M.2 running again?