Showing results for 
Search instead for 
Did you mean: 

Bricked GL553VW ( fixed )

Level 7


After struggling for hours with a bricked GL553VW after a Windows firmware update ( turned on, but no display ) , I finally managed to bring it back to life, not sure exactly how or what did the difference, but after a lot of reading and experimenting, I am sharing what I did that ( somehow ) worked.

- formatted a usb drive as FAT32.

- downloaded the latest BIOS from ASUS, and renamed it exactly as GL553VW.bin ( .bin in small letters ). I read a lot of info, like renaming it to .bin, .ROM, just copying it to the pen drive, then I came across a post from someone who renamed the file according to the laptop model, with the .bin extension ( in this case, GL553VW.bin it is ).

- removed the DVD drive and all HDD.

- turned on the computer while pressing the RIGHT ctrl + home keys.

After a few seconds, I saw the EZFLASH utility on the screen and it started flashing the file, after that the computer booted up normally.

I am not sure if all of this is necessary, but it whatever happened, it worked...

I am, however, still getting a "(A7) Me FW Downgrade - Request MeSpiLock Failed" message when I boot the computer, any idea of how to fix that?