cancel
Showing results for 
Search instead for 
Did you mean: 

Black screen after rog screen on startup

5thMagic
Level 7
I have a g750jx and I have done little to it except update to windows 8.1 from 8. However now when I start it windows doesn't seem to be loading, all I get is a black screen. I have tried using the f2 and f9 keys at start up but the result is the same. Any advice on steps I should take?
677 Views
17 REPLIES 17

Thanks, you suggest updating my bluetooth driver, but in the page under the g55 model for bluetooth drivers there are 3 available and I cant find which one is the one I have, there is qualcomm atheros, intel and broadcom. I also checked throught windows update and ausus update to see if my drivers where upt to date and nothing seems to be outdated. the model of my asus is g55vw s1024h. Also any news on whether ASUS or windows are working on any update to eliminate this isue anytime soon?

Ryuuken wrote:
Thanks, you suggest updating my bluetooth driver, but in the page under the g55 model for bluetooth drivers there are 3 available and I cant find which one is the one I have, there is qualcomm atheros, intel and broadcom. I also checked throught windows update and ausus update to see if my drivers where upt to date and nothing seems to be outdated. the model of my asus is g55vw s1024h. Also any news on whether ASUS or windows are working on any update to eliminate this isue anytime soon?


Ryuuken, you are in the wrong forum 🙂

The response I gave was for the G750, I didn't notice it was a problem on a different model.

Head over here and the people familiar with the G55 can help get it fixed for you.

http://rog.asus.com/forum/forumdisplay.php?146-G75-G55-amp-G46-Gaming-Notebooks

The bluetooth driver problem on the G750 when upgrading from Windows 8.0 to 8.1 may not translate to the G55.

Ryuuken wrote:
Thanks, you suggest updating my bluetooth driver, but in the page under the g55 model for bluetooth drivers there are 3 available and I cant find which one is the one I have, there is qualcomm atheros, intel and broadcom. I also checked throught windows update and ausus update to see if my drivers where upt to date and nothing seems to be outdated. the model of my asus is g55vw s1024h. Also any news on whether ASUS or windows are working on any update to eliminate this isue anytime soon?


Goto device manager and under Bluetooth settings right click on Bluetooth Module and select Properties. The name of the manufacturer would be written there. You can then download the drivers that best suit you. Depending on configuration you can have multiple Bluetooth devices listed. In that case check the Properties for each of them and select the best driver.
The Game is On!!! :cool:
G750JX-CV069P | i7-4700HQ | 24GB | 1.5TB HDD | 17.3" FHD 3D Screen | 3GB Nvidia GTX 770M

Ryuuken wrote:
I Just bough my ASUS G55 and I have the same problem after updating to windows 8.1.
when I start up the computer I can see the ROG logo loading but as soon as windows starts there is a black screen. I suspect it is in fact a driver problem, but I have already updated to 335.23 and it is still not fixed.
I found a temporary fix when this happens though. you just need to close the lid (this will put the computer in sleep mode) and power it up again. I am not sure why but this fixes the problem completely. also if you close it after turning it on it boots up normally, so this problem only arises (in my case anyway) when you either restart the computer or when you shut it down but you leave the lid open until the next use.

I would appreciate some help with this if anyone has been able to fix this successfully, or maybe some insight from the ROG people.


i am having the same problem with ASUS g55 win 10 version. everytime i restart the asus logo comes up and then it hangs up with black screen. everytime i have to repair it to work. only one month old laptop. if u get solution help me also

Crazy_Killer
Level 7
5thMagic wrote:
I have a g750jx and I have done little to it except update to windows 8.1 from 8. However now when I start it windows doesn't seem to be loading, all I get is a black screen. I have tried using the f2 and f9 keys at start up but the result is the same. Any advice on steps I should take?



i bought rog 1 month back but after a week or so whenever i open my rog lappy it hangs and black screen comes on or repair option comes every time i have to repair it. worst experience i have till now. windows 10 comes preinstalled . and its wont log on many times. help needed

Crazy Killer wrote:
i bought rog 1 month back but after a week or so whenever i open my rog lappy it hangs and black screen comes on or repair option comes every time i have to repair it. worst experience i have till now. windows 10 comes preinstalled . and its wont log on many times. help needed


Have you all updated nVidia drivers to latest version. G750JX laptops with 3D screens need to run only specific version of nVidia driver because generic drivers don't support 3D screens. Try downloading the nVidia driver from Asus Support page for your model, no matter how old the version is. Stick to it and also disable automatically download new drivers in GeForce Experience also
If you all are on Windows 10 you might need to tweak few more settings as MS will re-download the new driver for nVidia and you will have the same issue again. I faced the same problem when I bought my laptop and upgraded the nVidia drivers from nVidia website.
The Game is On!!! :cool:
G750JX-CV069P | i7-4700HQ | 24GB | 1.5TB HDD | 17.3" FHD 3D Screen | 3GB Nvidia GTX 770M

redduc900
Level 9
Will it boot into safe mode?

How to Start Windows 10 in Safe Mode
http://www.tenforums.com/tutorials/2304-safe-mode-start-windows-10-a.html
Laptop: Asus G750JZ
OS: Win10

rohan2812
Level 7
Have you all updated nVidia drivers to latest version. G750JX laptops with 3D screens need to run only specific version of nVidia driver because generic drivers don't support 3D screens. Try downloading the nVidia driver from Asus Support page for your model, no matter how old the version is. Stick to it and also disable automatically download new drivers in GeForce Experience also
If you all are on Windows 10 you might need to tweak few more settings as MS will re-download the new driver for nVidia and you will have the same issue again. I faced the same problem when I bought my laptop and upgraded the nVidia drivers from nVidia website.
The Game is On!!! :cool:
G750JX-CV069P | i7-4700HQ | 24GB | 1.5TB HDD | 17.3" FHD 3D Screen | 3GB Nvidia GTX 770M