cancel
Showing results for 
Search instead for 
Did you mean: 

Bios doesn't show USB drive as in boot menu

Randomuser
Level 7
Hello,

I'm an an owner of a G73J and I wanted to get rid of VSOD so I followed the article posted in this forum.
Unfortunately I'm stuck at the part where I need to boot from USB to update the vbios.
I have a bios version 2.11 and it only shows me hard-disk or cd-rom as options for booting.

Please help. How can I fix the bios so it will use my USB as a boot drive? Or is there some alternative?

Thanks.
18,383 Views
9 REPLIES 9

dstrakele
Level 14
Did you follow the procedure to make the flash drive bootable? If not, the BIOS ain't gonna list it in the Boot Device section.

Alternatively, have you tried a different flash drive or USB port?

I think you may also need to be at BIOS 213, but I'm unsure. Hopefully someone more familiar with the vbios update procedure could weigh-in here...
G74SX-A1 - stock hardware - BIOS 202 - 2nd Monitor VISIO VF551XVT

Yes I have. Done it to the letter.

dstrakele
Level 14
I added some additional text to my previous post that you may have missed.
G74SX-A1 - stock hardware - BIOS 202 - 2nd Monitor VISIO VF551XVT

Plunging the USB stick in other ports doesn't help.
I fear risking BIOS updating.

On a sidenote, when trying to create a new boot drive all it lets me do is pick between the two hard disks.

dstrakele
Level 14
I've seen another thread where a user couldn't get his flash drive detected as a boot device when trying to install Windows. He tried another flash drive and had no problems.

Alternatively, you could start from scratch by reformatting the flash drive with FAT32. Does Windows recognize the flash drive and the files on it when you plug it in?

If the device is bootable, it should appear in the Boot Devices list. My Android phone shows up there when I plug it in.

I realize you may fear BIOS updating, but a specific BIOS version may be a requirement for the vbios update procedure to suceed.

EDIT: I checked and see BIOS 211 or later is recommended, so you're OK there.
G74SX-A1 - stock hardware - BIOS 202 - 2nd Monitor VISIO VF551XVT

Thanks a lot mate.

After your probing I started having doubts so I trying making the bootable flash drive again.
I noticed in the HP USB program that the drive is named 0.00 (for some reason)
I found this in the BIOS as a boot option (it was there before but I completely overlooked it, because I looked for something related to USB).

Booted it. Update vbios.
Now Ill update drivers and hope VSOD will be a forgotten memory.

Again 🙂 thank you.

dstrakele
Level 14
Well, I always leave probing to the aliens, but I'm glad you got it working!
;>{)>

Your post about the drive name 0.00 will help others that may experience the same problem.
G74SX-A1 - stock hardware - BIOS 202 - 2nd Monitor VISIO VF551XVT

http://techshoptoday.blogspot.com/2013/08/asus-q300-usb-boot.html

so I needed the answer to the question and now a straight answer exists so far for this model. So here gos.

First turn on the machine while holding down the "del" key. this will get you into the bios. Then go over to the security tab, and disable "secure boot" and any other related security that you should assume you really don't need. Then finally go to the boot options tab, and enable "CSM" (Compatibility System Module). Now save and exit. Shut off the machine. Plug in your usb bootable drive. Now hold the "esc" key as you power on the machine and the boot device option screen will appear, and your usb drive should now be able to be selected and booted from.

this may or may not work for other models, but for some of the new machines with windows 8, this should apply accross the board.

trickyaamir
Level 7

If the USB option is not showing in the boot menu that means you have to disable the secure boot and enable the CSM support in bios, that will enable the boot option in the boot menu. Here is a video tutorial as well:  https://www.youtube.com/watch?v=PVlgCe1fAcw