cancel
Showing results for 
Search instead for 
Did you mean: 

ati mobility radeon hd 5870 - can't update drivers - BSOD atikmpag.sys error

zix
Level 7
Hi, I have a problem on my G73JH. Never tried to update video drivers before, but decided now, since GTA 5 won't work properly (it got stuck on 800x600, and shows only 512 mb of video memory in settings). Therefore, I downloaded different versions of graphic drivers - Omega 14.12, 15.5 beta, and none of them can't be installed, when it comes to screen testing and flickering part, seconds after i get BSOD and ATIKMPAG.SYS error, and windows restarts and i have to roll back drivers, since the screen resolution get messed up. Does anyone knows how to fix this problem, and install latest drivers version, that would be highly appreciated. Thanks in advance
4,882 Views
2 REPLIES 2

billyray520
Level 10
Did you update the vBios first?
Asus Maximus V Extreme BIOS 1903, see specs above avatar.

Asus G73 jh A1 laptop, BIOS 213, vBIOS OD2, 8 GB Ram, 240 GB Intel SSD, 180 GB Intel SSD. Win 7 Pro. Purchased new from PowerNotebooks.com in May 2010.
(both have 1920X1080 hd screens, mine above, hers below )
Asus G73 Sw XR1 laptop 8 GB Ram, 160 GB Intel SSD, 80 GB Intel SSD. Purchased used >Ebay 1/10/13, Did clean install of Windows 7

Yes, i did update vBios, couple a years ago. I fixed it yesterday, just initiated windows update, had over 120 new updates, and after that all went well, installed 14.12 version. Now works great, plus the GPU temperature on idle is now 10 degrees Celsius lower :D. Anyways, thanks for the replay.